summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-23 16:45:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-23 23:15:54 +0200
commite8f2ddbb23b1f97a099c9c44c4220c24ef1a1394 (patch)
tree5ffbdd08e6521bdc2b5137a5fcf4fd64f77dff8d
parent2537a7bf26a01d393822e0618729b929db93e5cb (diff)
downloadguix-patches-e8f2ddbb23b1f97a099c9c44c4220c24ef1a1394.tar
guix-patches-e8f2ddbb23b1f97a099c9c44c4220c24ef1a1394.tar.gz
gnu: Add python-progressbar2.
* gnu/packages/python-xyz.scm (python-progressbar2): New variable.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 77f1ff72f3..a46c1f6172 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9883,6 +9883,38 @@ concurrent.futures package from Python 3.2")
("python2-pytest" ,python2-pytest)
,@(package-native-inputs promise))))))
+(define-public python-progressbar2
+ (package
+ (name "python-progressbar2")
+ (version "3.51.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "progressbar2" version))
+ (sha256
+ (base32
+ "0b2v3mim90rmfvixkaniz2qrs650sk230rzgd5zhcjfldmlqgxpc"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-utils" ,python-utils)))
+ (native-inputs
+ `(("python-flake8" ,python-flake8)
+ ("python-freezegun" ,python-freezegun)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cache" ,python-pytest-cache)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-flakes" ,python-pytest-flakes)
+ ("python-pytest-pep8" ,python-pytest-pep8)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/WoLpH/python-progressbar")
+ (synopsis "Text progress bar library for Python")
+ (description
+ "This package provides a Python progressbar library to provide
+visual (yet text based) progress to long running operations.")
+ (license license:bsd-3)))
+
(define-public python-progressbar33
(package
(name "python-progressbar33")