summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:04:50 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:18 +0200
commit35044d3e3ef183fd3b6986e3a86d6c7a1c8164a4 (patch)
tree8e1685aa5f35c63c76046a8d6055b977e37a7397
parent9f7b5990378c4bf609c327bfc767fee6071c9ee2 (diff)
downloadguix-patches-35044d3e3ef183fd3b6986e3a86d6c7a1c8164a4.tar
guix-patches-35044d3e3ef183fd3b6986e3a86d6c7a1c8164a4.tar.gz
gnu: Add julia-constructionbase.
* gnu/packages/julia-xyz.scm (julia-constructionbase): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0d35cbde57..7fbb18347f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020, 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -117,6 +118,27 @@ provides a macro that lets you use the latest syntax in a backwards-compatible
way.")
(license license:expat)))
+(define-public julia-constructionbase
+ (let ((commit "de77e2865b554f9b078fd8c35b593cce0554ae02"))
+ (package
+ (name "julia-constructionbase")
+ (version "1.1.0") ;tag not created upstream
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaObjects/ConstructionBase.jl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y79sfj0rds1skl9j16p9161hwa9khm0xc2m4hgjcbh5zzvyr57v"))))
+ (build-system julia-build-system)
+ (home-page "https://juliaobjects.github.io/ConstructionBase.jl/dev/")
+ (synopsis "Primitive functions for construction of objects")
+ (description "This very lightweight package provides primitive functions
+for construction of objects.")
+ (license license:expat))))
+
(define-public julia-datastructures
(package
(name "julia-datastructures")