summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-30 17:40:01 +0100
committerMarius Bakke <marius@gnu.org>2022-02-01 23:46:04 +0100
commit7ad2cfcc7227b0aeabeae4f2f89bb9631eb9ab98 (patch)
tree6ba7aeaf96510f89e26b9918b66a79a7aebc20ad
parent018d2c12430495ffe86dcbe2fb59d1f0144a3fe6 (diff)
downloadguix-patches-7ad2cfcc7227b0aeabeae4f2f89bb9631eb9ab98.tar
guix-patches-7ad2cfcc7227b0aeabeae4f2f89bb9631eb9ab98.tar.gz
gnu: json-modern-cxx: Remove input labels.
* gnu/packages/cpp.scm (json-modern-cxx)[native-inputs]: Remove labels. [arguments]: Use SEARCH-INPUT-FILE.
-rw-r--r--gnu/packages/cpp.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 9927d79e37..5b4eee151f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -528,7 +528,9 @@ as ordering relation.")
'(#:configure-flags
(list "-DJSON_MultipleHeaders=ON" ; For json_fwd.hpp.
(string-append "-DJSON_TestDataDirectory="
- (assoc-ref %build-inputs "json_test_data")))
+ (dirname
+ (search-input-directory %build-inputs
+ "json_nlohmann_tests"))))
#:phases (modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? parallel-tests? #:allow-other-keys)
@@ -540,19 +542,17 @@ as ordering relation.")
"1"))
(format #t "test suite not run~%")))))))
(native-inputs
- `(("amalgamate" ,amalgamate)
- ("doctest" ,doctest)
- ("json_test_data"
- ,(let ((version "3.0.0"))
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nlohmann/json_test_data")
- (commit (string-append "v" version))))
- (file-name (git-file-name "json_test_data" version))
- (sha256
- (base32
- "0nzsjzlvk14dazwh7k2jb1dinb0pv9jbx5jsyn264wvva0y7daiv")))))))
+ (list amalgamate doctest
+ (let ((version "3.0.0"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nlohmann/json_test_data")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "json_test_data" version))
+ (sha256
+ (base32
+ "0nzsjzlvk14dazwh7k2jb1dinb0pv9jbx5jsyn264wvva0y7daiv"))))))
(inputs
(list fifo-map))
(synopsis "JSON parser and printer library for C++")