summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-02-01 20:00:31 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-02-01 20:06:25 +0100
commit787b13a5d9df8f0cc7170de1b80cead68b516c66 (patch)
tree1399b14d16ea0ebacbfd587bfc07c7cb0529ee71
parentf07459ea05c06b8bc7dff92285e652d2449dd45b (diff)
downloadguix-patches-787b13a5d9df8f0cc7170de1b80cead68b516c66.tar
guix-patches-787b13a5d9df8f0cc7170de1b80cead68b516c66.tar.gz
gnu: librecad: Fix build with boost 1.76.
Fixes <https://issues.guix.gnu.org/53694>. * gnu/packages/patches/librecad-support-for-boost-1.76.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/engineering.scm (librecad)[source]: Use it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/engineering.scm4
-rw-r--r--gnu/packages/patches/librecad-support-for-boost-1.76.patch17
3 files changed, 21 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1788c4e110..9969bc67cb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1408,6 +1408,7 @@ dist_patch_DATA = \
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
%D%/packages/patches/libqalculate-3.8.0-libcurl-ssl-fix.patch \
%D%/packages/patches/libquicktime-ffmpeg.patch \
+ %D%/packages/patches/librecad-support-for-boost-1.76.patch \
%D%/packages/patches/libssh2-CVE-2019-17498.patch \
%D%/packages/patches/libtar-CVE-2013-4420.patch \
%D%/packages/patches/libtgvoip-disable-sse2.patch \
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8e4614590b..04f5ba88b9 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -147,7 +147,9 @@
(file-name (git-file-name name version))
(sha256
(base32
- "08cl4935c9vznz9qdw1zgd86rn7hl64zpfayxl07x21bhf53pn24"))))
+ "08cl4935c9vznz9qdw1zgd86rn7hl64zpfayxl07x21bhf53pn24"))
+ (patches
+ (search-patches "librecad-support-for-boost-1.76.patch"))))
(build-system qt-build-system)
(arguments
'(#:test-target "check"
diff --git a/gnu/packages/patches/librecad-support-for-boost-1.76.patch b/gnu/packages/patches/librecad-support-for-boost-1.76.patch
new file mode 100644
index 0000000000..aa352e669f
--- /dev/null
+++ b/gnu/packages/patches/librecad-support-for-boost-1.76.patch
@@ -0,0 +1,17 @@
+Upstream commit e02f3580311d50b617427652ff77988f6bd62d9d adding Boost 1.76
+compatibility.
+
+diff --git a/librecad/src/lib/engine/rs_ellipse.cpp b/librecad/src/lib/engine/rs_ellipse.cpp
+index 291f734ea..d47bf6ca4 100644
+--- a/librecad/src/lib/engine/rs_ellipse.cpp
++++ b/librecad/src/lib/engine/rs_ellipse.cpp
+@@ -48,6 +48,9 @@
+ #include <boost/version.hpp>
+ #include <boost/math/tools/roots.hpp>
+ #include <boost/math/special_functions/ellint_2.hpp>
++#if BOOST_VERSION > 104500
++#include <boost/math/tools/tuple.hpp>
++#endif
+ #endif
+
+ namespace{