summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-06-15 11:22:57 -0400
committerEfraim Flashner <efraim@flashner.co.il>2020-10-28 10:34:04 +0200
commit0569a832683e686b1ec949bcc3e3e4069929cb95 (patch)
treeffdca7c466f33e4029670c3f13930a8bda5e90a9
parentcf8799254f67a50ba9fdc607fede28072f4a22e0 (diff)
downloadguix-patches-0569a832683e686b1ec949bcc3e3e4069929cb95.tar
guix-patches-0569a832683e686b1ec949bcc3e3e4069929cb95.tar.gz
gnu: icedtea-8: Fix build on aarch64-linux.
* gnu/packages/java.scm (icedtea-8)[native-inputs]: Remove obsolete, architecture-dependent patch to "hotspot-drop". * gnu/packages/patches/icedtea-7-hotspot-gcc-segfault-workaround.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/java.scm12
-rw-r--r--gnu/packages/patches/icedtea-7-hotspot-gcc-segfault-workaround.patch45
3 files changed, 2 insertions, 56 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 85de4e4995..04f577399f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1147,7 +1147,6 @@ dist_patch_DATA = \
%D%/packages/patches/icecat-use-system-media-libs.patch \
%D%/packages/patches/icedtea-6-extend-hotspot-aarch64-support.patch \
%D%/packages/patches/icedtea-7-hotspot-aarch64-use-c++98.patch \
- %D%/packages/patches/icedtea-7-hotspot-gcc-segfault-workaround.patch \
%D%/packages/patches/icu4c-CVE-2020-10531.patch \
%D%/packages/patches/id3lib-CVE-2007-4460.patch \
%D%/packages/patches/id3lib-UTF16-writing-bug.patch \
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 921526eb02..9ced80cecf 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1855,16 +1855,8 @@ new Date();"))
,(drop "langtools"
"15wizy123vhk40chl1b4p552jf2pw2hdww0myf11qab425axz4nw"))
("hotspot-drop"
- ,(origin
- (method url-fetch)
- (uri (string-append
- "http://icedtea.classpath.org/download/drops"
- "/icedtea8/" version "/hotspot.tar.xz"))
- (sha256
- (base32
- "1ciz1w9j0kz7s1dxdhyqq71nla9icyz6qvn0b9z2zgkklqa98qmm"))
- (patches (search-patches
- "icedtea-7-hotspot-gcc-segfault-workaround.patch"))))
+ ,(drop "hotspot"
+ "1ciz1w9j0kz7s1dxdhyqq71nla9icyz6qvn0b9z2zgkklqa98qmm"))
("nashorn-drop"
,(drop "nashorn"
"19pzl3ppaw8j6r5cnyp8qiw3hxijh3hdc46l39g5yfhdl4pr4hpa"))
diff --git a/gnu/packages/patches/icedtea-7-hotspot-gcc-segfault-workaround.patch b/gnu/packages/patches/icedtea-7-hotspot-gcc-segfault-workaround.patch
deleted file mode 100644
index 35cfe38152..0000000000
--- a/gnu/packages/patches/icedtea-7-hotspot-gcc-segfault-workaround.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 2f0ef2c69e99e1096a2a72c7a29025a736b044b4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?G=C3=A1bor=20Boskovits?= <boskovits@gmail.com>
-Date: Mon, 2 Jul 2018 23:37:25 +0200
-Subject: [PATCH] Fix gcc segfault.
-
----
- src/share/vm/opto/output.cpp | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/src/share/vm/opto/output.cpp b/src/share/vm/opto/output.cpp
-index d46cb87..0eb9eda 100644
---- a/src/share/vm/opto/output.cpp
-+++ b/src/share/vm/opto/output.cpp
-@@ -1787,6 +1787,8 @@ uint Scheduling::_total_instructions_per_bundle[Pipeline::_max_instrs_per_cycle+
-
- // Initializer for class Scheduling
-
-+volatile const void *eePointer = Pipeline_Use::elaborated_elements;
-+
- Scheduling::Scheduling(Arena *arena, Compile &compile)
- : _arena(arena),
- _cfg(compile.cfg()),
-@@ -1829,7 +1831,7 @@ Scheduling::Scheduling(Arena *arena, Compile &compile)
- memset(_current_latency, 0, node_max * sizeof(unsigned short));
-
- // Clear the bundling information
-- memcpy(_bundle_use_elements, Pipeline_Use::elaborated_elements, sizeof(Pipeline_Use::elaborated_elements));
-+ memcpy(_bundle_use_elements, (void *)eePointer, 11*sizeof(Pipeline_Use_Element));
-
- // Get the last node
- Block* block = _cfg->get_block(_cfg->number_of_blocks() - 1);
-@@ -1880,8 +1882,8 @@ void Scheduling::step_and_clear() {
- _bundle_use.reset();
-
- memcpy(_bundle_use_elements,
-- Pipeline_Use::elaborated_elements,
-- sizeof(Pipeline_Use::elaborated_elements));
-+ (void *)eePointer,
-+ 11*sizeof(Pipeline_Use_Element));
- }
-
- // Perform instruction scheduling and bundling over the sequence of
---
-2.18.0
-