summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorterramorpha <terramorpha@cock.li>2021-07-12 12:38:57 -0400
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-07-15 20:55:42 +0200
commita49c5488bd9d3b9874947ad80a04d97bd1cf11d9 (patch)
tree61cf556fa65b20a829e8b2b306944240fffa4ed4
parent7e0da2f1804bc14fc8e42edee234e0b40f3d3d22 (diff)
downloadguix-patches-a49c5488bd9d3b9874947ad80a04d97bd1cf11d9.tar
guix-patches-a49c5488bd9d3b9874947ad80a04d97bd1cf11d9.tar.gz
gnu: Add putty.
* gnu/packages/networking.scm (putty): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
-rw-r--r--gnu/packages/networking.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 65a8db83fe..304c8a8703 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4143,3 +4143,36 @@ on hub/switched networks. It is based on @acronym{ARP} packets, it will send
@acronym{ARP} requests and sniff for replies.")
(home-page "https://github.com/netdiscover-scanner/netdiscover")
(license license:gpl3+)))
+
+(define-public putty
+ (package
+ (name "putty")
+ (version "0.75")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.putty.be/" version
+ "/putty-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xgrr1fbirw79zafspg2b6crzfmlfw910y79md4r7gnxgq1kn5yk"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "unix")
+ #t)))))
+ (inputs
+ `(("gtk+" ,gtk+)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python))) ; for tests
+ (synopsis "Graphical @acronym{SSH} and telnet client")
+ (description "Putty is a terminal client. It supports @acronym{SSH},
+telnet, and raw socket connections with good terminal emulation. It supports
+public key authentication and Kerberos single-sign-on. It also includes
+command-line @acronym{SFTP} and @acronym{SCP} implementations.")
+ (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
+ (license license:expat)))