summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-27 08:57:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-27 08:57:15 +0300
commit8e220c23320c747d9bbe551f4545c5088ad0f494 (patch)
treea2f2946dc72ac4123fffc2cb363753af864b38b7
parente187ce20d2bc72899cfb3b1b7550302c292e97df (diff)
downloadguix-patches-8e220c23320c747d9bbe551f4545c5088ad0f494.tar
guix-patches-8e220c23320c747d9bbe551f4545c5088ad0f494.tar.gz
gnu: python-graphql-relay: Enable tests.
* gnu/packages/python-xyz.scm (python-graphql-relay)[arguments]: Use custom 'check phase. [native-inputs]: Add python-pytest, python-pytest-asyncio.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dac6a9a03f..9821e9288e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16111,7 +16111,16 @@ to Python.")
"1d70vwam9gjhx7fqzsa03x7lc6ivcqki5r9pk8m7rslmb7pagmbh"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ; The tests are not distributed
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "tests")))))))
+ (native-inputs
+ (list
+ python-pytest
+ python-pytest-asyncio))
(propagated-inputs
`(("python-graphql-core" ,python-graphql-core)))
(home-page "https://github.com/graphql-python/graphql-relay-py")