summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-15 10:56:22 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-15 11:35:03 +0000
commit373d2099c9def2c21ea6528f0954b8ba63176f8f (patch)
tree8b1949700562be3744e32966ab6c8d57eca90323
parentf2d55971453bd11f43c2734f91c42005ee314091 (diff)
downloadguix-patches-373d2099c9def2c21ea6528f0954b8ba63176f8f.tar
guix-patches-373d2099c9def2c21ea6528f0954b8ba63176f8f.tar.gz
gnu: Add python-hnswlib.
* gnu/packages/python-xyz.scm (python-hnswlib): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 79ac39e817..e9ec280083 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1369,6 +1369,27 @@ concepts.")
(define-public python2-h5py
(package-with-python2 python-h5py))
+(define-public python-hnswlib
+ (package
+ (name "python-hnswlib")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hnswlib" version))
+ (sha256
+ (base32 "0wf1cwmxmdzfqmfhrkqdxb5spf21ylgl2bidswhzjrqhwf35c9qf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (native-inputs
+ `(("pybind11" ,pybind11)))
+ (home-page "https://github.com/nmslib/hnswlib")
+ (synopsis "Fast approximate nearest neighbor search")
+ (description "Hnswlib is a header-only C++ implementation of fast
+approximate nearest neighbor search with Python bindings.")
+ (license license:asl2.0)))
+
(define-public python-pyls-black
(package
(name "python-pyls-black")