summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:37:59 +0200
commitff65fa90d268bbe3f868be4cb5d9e2bb5ab6c3dd (patch)
treec58fc2560c503ca6e9a4c3d24d85de4993d8a241
parent84019edf38fea7ded047464fa4a6c79675934ae4 (diff)
downloadguix-patches-ff65fa90d268bbe3f868be4cb5d9e2bb5ab6c3dd.tar
guix-patches-ff65fa90d268bbe3f868be4cb5d9e2bb5ab6c3dd.tar.gz
gnu: r-complexheatmap: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-complexheatmap): Move from here... * gnu/packages/bioconductor.scm (r-complexheatmap): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm39
-rw-r--r--gnu/packages/bioinformatics.scm39
2 files changed, 39 insertions, 39 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a0ee8a8c18..3e536e0299 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2287,6 +2287,45 @@ genome data packages and support for efficient SNP representation.")
analysis.")
(license license:artistic2.0)))
+(define-public r-complexheatmap
+ (package
+ (name "r-complexheatmap")
+ (version "2.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ComplexHeatmap" version))
+ (sha256
+ (base32
+ "1nx1xxpq8zrvi990v9fmvx3msl85pdz5dp1gp6m78q6i4s2alg5x"))))
+ (properties
+ `((upstream-name . "ComplexHeatmap")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cairo" ,r-cairo)
+ ("r-circlize" ,r-circlize)
+ ("r-clue" ,r-clue)
+ ("r-colorspace" ,r-colorspace)
+ ("r-digest" ,r-digest)
+ ("r-getoptlong" ,r-getoptlong)
+ ("r-globaloptions" ,r-globaloptions)
+ ("r-iranges" ,r-iranges)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-png" ,r-png)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/jokergoo/ComplexHeatmap")
+ (synopsis "Making Complex Heatmaps")
+ (description
+ "Complex heatmaps are efficient to visualize associations between
+different sources of data sets and reveal potential structures. This package
+provides a highly flexible way to arrange multiple heatmaps and supports
+self-defined annotation graphics.")
+ (license license:gpl2+)))
+
(define-public r-deseq
(package
(name "r-deseq")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a857c1ccc5..a57c420a07 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9202,45 +9202,6 @@ distributed by file or by range. User defined mapper and reducer functions
provide added flexibility for data combination and manipulation.")
(license license:artistic2.0)))
-(define-public r-complexheatmap
- (package
- (name "r-complexheatmap")
- (version "2.6.2")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "ComplexHeatmap" version))
- (sha256
- (base32
- "1nx1xxpq8zrvi990v9fmvx3msl85pdz5dp1gp6m78q6i4s2alg5x"))))
- (properties
- `((upstream-name . "ComplexHeatmap")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-cairo" ,r-cairo)
- ("r-circlize" ,r-circlize)
- ("r-clue" ,r-clue)
- ("r-colorspace" ,r-colorspace)
- ("r-digest" ,r-digest)
- ("r-getoptlong" ,r-getoptlong)
- ("r-globaloptions" ,r-globaloptions)
- ("r-iranges" ,r-iranges)
- ("r-matrixstats" ,r-matrixstats)
- ("r-png" ,r-png)
- ("r-rcolorbrewer" ,r-rcolorbrewer)
- ("r-s4vectors" ,r-s4vectors)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page
- "https://github.com/jokergoo/ComplexHeatmap")
- (synopsis "Making Complex Heatmaps")
- (description
- "Complex heatmaps are efficient to visualize associations between
-different sources of data sets and reveal potential structures. This package
-provides a highly flexible way to arrange multiple heatmaps and supports
-self-defined annotation graphics.")
- (license license:gpl2+)))
-
(define-public r-dirichletmultinomial
(package
(name "r-dirichletmultinomial")