summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 17:12:19 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:58 +0200
commitf8ae2ee528be1b9d92a61b6dc6b470821e645afd (patch)
tree0475f8ec419bfe680d89439a5113085a8add5aba
parent73bfc125ef61980920cd01691032153deba4b98d (diff)
downloadguix-patches-f8ae2ee528be1b9d92a61b6dc6b470821e645afd.tar
guix-patches-f8ae2ee528be1b9d92a61b6dc6b470821e645afd.tar.gz
gnu: Add ruby-safe-yaml.
* gnu/packages/ruby.scm (ruby-safe-yaml): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 34d883284d..3f0cfcfcfa 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5765,3 +5765,26 @@ fact is that most parsers are insensitive to indentation. If, however, the
strings are to be used otherwise, be it for printing or testing, the extra
indentation will probably be an issue and hence this gem.")
(license license:expat)))
+
+(define-public ruby-safe-yaml
+ (package
+ (name "ruby-safe-yaml")
+ (version "1.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "safe_yaml" version))
+ (sha256
+ (base32
+ "1hly915584hyi9q9vgd968x2nsi5yag9jyf5kq60lwzi5scr7094"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("ruby-hashie" ,ruby-hashie)
+ ("ruby-heredoc-unindent" ,ruby-heredoc-unindent)))
+ (arguments `(#:test-target "spec"
+ #:tests? #f));; FIXME: one failure
+ (home-page "https://github.com/dtao/safe_yaml")
+ (synopsis "YAML parser")
+ (description "The SafeYAML gem provides an alternative implementation of
+YAML.load suitable for accepting user input in Ruby applications.")
+ (license license:expat)))