summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-30 17:28:43 +0100
committerMarius Bakke <marius@gnu.org>2022-02-01 23:46:04 +0100
commitf89bf66690e6863a822d756a39242bd0b998d3e5 (patch)
tree9b37b2aba9da03a7ed153e2a78049ff68f0b8204
parent2b4aeda7559b458d8308151f2b2935831d18826b (diff)
downloadguix-patches-f89bf66690e6863a822d756a39242bd0b998d3e5.tar
guix-patches-f89bf66690e6863a822d756a39242bd0b998d3e5.tar.gz
gnu: fifo-map: Use a release tag.
* gnu/packages/cpp.scm (fifo-map): Update to 1.0.0, which is one (inconsequential) commit ahead of our custom "1.1.1" version. [arguments]: Respect TESTS? in check phase while at it.
-rw-r--r--gnu/packages/cpp.scm73
1 files changed, 35 insertions, 38 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index a1596314dc..9eddae626e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -452,46 +452,43 @@ functions, class methods, and stl containers.
(license license:bsd-3)))
(define-public fifo-map
- (let* ((commit "0dfbf5dacbb15a32c43f912a7e66a54aae39d0f9")
- (revision "0")
- (version (git-version "1.1.1" revision commit)))
- (package
- (name "fifo-map")
- (version version)
- (home-page "https://github.com/nlohmann/fifo_map")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit commit)))
- (sha256
- (base32
- "0pi77b75kp0l7z454ihcd14nzpi3nc5m4nyjbsgy5f9bw3676196"))
- (patches (search-patches "fifo-map-remove-catch.hpp.patch"
- "fifo-map-fix-flags-for-gcc.patch"))
- (file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet '(delete-file-recursively "./test/thirdparty"))))
- (native-inputs
- (list catch-framework2-1))
- (build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "./unit")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (inc (string-append out "/include/fifo_map")))
- (with-directory-excursion "../source"
- (install-file "src/fifo_map.hpp" inc))))))))
- (synopsis "FIFO-ordered associative container for C++")
- (description "Fifo_map is a C++ header only library for associative
+ (package
+ (name "fifo-map")
+ (version "1.0.0")
+ (home-page "https://github.com/nlohmann/fifo_map")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0y59fk6ycrgjln9liwcja3l5j1vxpa5i671bynpbsjlyq5f2560q"))
+ (patches (search-patches "fifo-map-remove-catch.hpp.patch"
+ "fifo-map-fix-flags-for-gcc.patch"))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "./test/thirdparty"))))
+ (native-inputs
+ (list catch-framework2-1))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "./unit"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (inc (string-append out "/include/fifo_map")))
+ (with-directory-excursion "../source"
+ (install-file "src/fifo_map.hpp" inc))))))))
+ (synopsis "FIFO-ordered associative container for C++")
+ (description "Fifo_map is a C++ header only library for associative
container which uses the order in which keys were inserted to the container
as ordering relation.")
- (license license:expat))))
+ (license license:expat)))
(define-public json-modern-cxx
(package