summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:37:58 +0200
commitf6f43a2d40e830243d118f740d164d3fe1b79bba (patch)
tree1be4eaf89b28c138f56fe2011850300aa49ad140
parentef954bb4884185466bc4833c365ecb01be3a0a20 (diff)
downloadguix-patches-f6f43a2d40e830243d118f740d164d3fe1b79bba.tar
guix-patches-f6f43a2d40e830243d118f740d164d3fe1b79bba.tar.gz
gnu: r-edaseq: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-edaseq): Move from here... * gnu/packages/bioconductor.scm (r-edaseq): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm40
-rw-r--r--gnu/packages/bioinformatics.scm40
2 files changed, 40 insertions, 40 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 65dfce04bd..7e6b48eb19 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2332,6 +2332,46 @@ testing. The package also provides functions for the visualization and
exploration of the results.")
(license license:gpl3+)))
+(define-public r-edaseq
+ (package
+ (name "r-edaseq")
+ (version "2.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "EDASeq" version))
+ (sha256
+ (base32
+ "0fznj7lsgkss1svv4rq8g87s1gmnbd7hccim41dv1c2w2nl0n2ip"))))
+ (properties `((upstream-name . "EDASeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-aroma-light" ,r-aroma-light)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocmanager" ,r-biocmanager)
+ ("r-biomart" ,r-biomart)
+ ("r-biostrings" ,r-biostrings)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-shortread" ,r-shortread)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/drisso/EDASeq")
+ (synopsis "Exploratory data analysis and normalization for RNA-Seq")
+ (description
+ "This package provides support for numerical and graphical summaries of
+RNA-Seq genomic read data. Provided within-lane normalization procedures to
+adjust for GC-content effect (or other gene-level effects) on read counts:
+loess robust local regression, global-scaling, and full-quantile
+normalization. Between-lane normalization procedures to adjust for
+distributional differences between lanes (e.g., sequencing depth):
+global-scaling and full-quantile normalization.")
+ (license license:artistic2.0)))
+
(define-public r-edger
(package
(name "r-edger")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d23c3cb94e..87ba47e2e4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9196,46 +9196,6 @@ their variance is independent of the mean, and they are usually more sensitive
and specific in detecting differential transcription.")
(license license:artistic2.0)))
-(define-public r-edaseq
- (package
- (name "r-edaseq")
- (version "2.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "EDASeq" version))
- (sha256
- (base32
- "0fznj7lsgkss1svv4rq8g87s1gmnbd7hccim41dv1c2w2nl0n2ip"))))
- (properties `((upstream-name . "EDASeq")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotationdbi" ,r-annotationdbi)
- ("r-aroma-light" ,r-aroma-light)
- ("r-biobase" ,r-biobase)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-biocmanager" ,r-biocmanager)
- ("r-biomart" ,r-biomart)
- ("r-biostrings" ,r-biostrings)
- ("r-genomicfeatures" ,r-genomicfeatures)
- ("r-genomicranges" ,r-genomicranges)
- ("r-iranges" ,r-iranges)
- ("r-rsamtools" ,r-rsamtools)
- ("r-shortread" ,r-shortread)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://github.com/drisso/EDASeq")
- (synopsis "Exploratory data analysis and normalization for RNA-Seq")
- (description
- "This package provides support for numerical and graphical summaries of
-RNA-Seq genomic read data. Provided within-lane normalization procedures to
-adjust for GC-content effect (or other gene-level effects) on read counts:
-loess robust local regression, global-scaling, and full-quantile
-normalization. Between-lane normalization procedures to adjust for
-distributional differences between lanes (e.g., sequencing depth):
-global-scaling and full-quantile normalization.")
- (license license:artistic2.0)))
-
(define-public r-interactivedisplaybase
(package
(name "r-interactivedisplaybase")