summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:35:53 +0200
commitf3b50aa4fd0c431814c70f02fea62bfcffeebbd4 (patch)
tree48962a419fae24d4d9b526b2b22c49838fe52ea8
parent14fb30e5f68dca6c64508ce3accce0a1722b118b (diff)
downloadguix-patches-f3b50aa4fd0c431814c70f02fea62bfcffeebbd4.tar
guix-patches-f3b50aa4fd0c431814c70f02fea62bfcffeebbd4.tar.gz
gnu: r-go-db: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-go-db): Move from here... * gnu/packages/bioconductor.scm (r-go-db): ...to here. [source]: Replace 'string-append' by 'bioconductor-uri' with 'annotation.
-rw-r--r--gnu/packages/bioconductor.scm22
-rw-r--r--gnu/packages/bioinformatics.scm24
2 files changed, 22 insertions, 24 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d386f2270e..8cf8b43ed4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -436,6 +436,28 @@ in Biostrings objects.")
ID and species. It is used by functions in the GenomeInfoDb package.")
(license license:artistic2.0)))
+(define-public r-go-db
+ (package
+ (name "r-go-db")
+ (version "3.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GO.db" version 'annotation))
+ (sha256
+ (base32
+ "0i3wcf5h3n0dawzc1hy0kv74f06j80c47n4p3g3fmrcxlhi3jpa5"))))
+ (properties
+ `((upstream-name . "GO.db")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)))
+ (home-page "https://bioconductor.org/packages/GO.db")
+ (synopsis "Annotation maps describing the entire Gene Ontology")
+ (description
+ "The purpose of this GO.db annotation package is to provide detailed
+information about the latest version of the Gene Ontologies.")
+ (license license:artistic2.0)))
+
(define-public r-homo-sapiens
(package
(name "r-homo-sapiens")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fa57451bdc..1396631591 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7952,30 +7952,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-go-db
- (package
- (name "r-go-db")
- (version "3.7.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.bioconductor.org/packages/"
- "release/data/annotation/src/contrib/GO.db_"
- version ".tar.gz"))
- (sha256
- (base32
- "0i3wcf5h3n0dawzc1hy0kv74f06j80c47n4p3g3fmrcxlhi3jpa5"))))
- (properties
- `((upstream-name . "GO.db")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotationdbi" ,r-annotationdbi)))
- (home-page "https://bioconductor.org/packages/GO.db")
- (synopsis "Annotation maps describing the entire Gene Ontology")
- (description
- "The purpose of this GO.db annotation package is to provide detailed
-information about the latest version of the Gene Ontologies.")
- (license license:artistic2.0)))
-
(define-public r-spp
(package
(name "r-spp")