summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:37:58 +0200
commitef954bb4884185466bc4833c365ecb01be3a0a20 (patch)
treef7b6ba067a457d1cbe85b4f466c742d2c8d83296
parentbb118f20fe6581a4acbd3799ed31ab0d21e72e78 (diff)
downloadguix-patches-ef954bb4884185466bc4833c365ecb01be3a0a20.tar
guix-patches-ef954bb4884185466bc4833c365ecb01be3a0a20.tar.gz
gnu: r-deseq: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-deseq): Move from here... * gnu/packages/bioconductor.scm (r-deseq): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm31
-rw-r--r--gnu/packages/bioinformatics.scm31
2 files changed, 31 insertions, 31 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3f057a3a4d..65dfce04bd 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2218,6 +2218,37 @@ genome data packages and support for efficient SNP representation.")
analysis.")
(license license:artistic2.0)))
+(define-public r-deseq
+ (package
+ (name "r-deseq")
+ (version "1.39.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DESeq" version))
+ (sha256
+ (base32
+ "047hph5aqmjnz1aqprziw0smdn5lf96hmwpnvqrxv1j2yfvcf3h1"))))
+ (properties `((upstream-name . "DESeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-genefilter" ,r-genefilter)
+ ("r-geneplotter" ,r-geneplotter)
+ ("r-lattice" ,r-lattice)
+ ("r-locfit" ,r-locfit)
+ ("r-mass" ,r-mass)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)))
+ (home-page "https://www-huber.embl.de/users/anders/DESeq/")
+ (synopsis "Differential gene expression analysis")
+ (description
+ "This package provides tools for estimating variance-mean dependence in
+count data from high-throughput genetic sequencing assays and for testing for
+differential expression based on a model using the negative binomial
+distribution.")
+ (license license:gpl3+)))
+
(define-public r-deseq2
(package
(name "r-deseq2")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 687da8086e..d23c3cb94e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9196,37 +9196,6 @@ their variance is independent of the mean, and they are usually more sensitive
and specific in detecting differential transcription.")
(license license:artistic2.0)))
-(define-public r-deseq
- (package
- (name "r-deseq")
- (version "1.39.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "DESeq" version))
- (sha256
- (base32
- "047hph5aqmjnz1aqprziw0smdn5lf96hmwpnvqrxv1j2yfvcf3h1"))))
- (properties `((upstream-name . "DESeq")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biobase" ,r-biobase)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-genefilter" ,r-genefilter)
- ("r-geneplotter" ,r-geneplotter)
- ("r-lattice" ,r-lattice)
- ("r-locfit" ,r-locfit)
- ("r-mass" ,r-mass)
- ("r-rcolorbrewer" ,r-rcolorbrewer)))
- (home-page "https://www-huber.embl.de/users/anders/DESeq/")
- (synopsis "Differential gene expression analysis")
- (description
- "This package provides tools for estimating variance-mean dependence in
-count data from high-throughput genetic sequencing assays and for testing for
-differential expression based on a model using the negative binomial
-distribution.")
- (license license:gpl3+)))
-
(define-public r-edaseq
(package
(name "r-edaseq")