summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:37:55 +0200
commitd7fa9c1ffdbd0ab4d4412020c925be39503ce9e8 (patch)
tree7288e40d4be2054317f24c9c6c6f3e688f2b34ce
parentf8fe5497c7b9f598786d46d96fd1bd5002e7e57f (diff)
downloadguix-patches-d7fa9c1ffdbd0ab4d4412020c925be39503ce9e8.tar
guix-patches-d7fa9c1ffdbd0ab4d4412020c925be39503ce9e8.tar.gz
gnu: r-genomationdata: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-genomationdata): Move from here... * gnu/packages/bioconductor.scm (r-genomationdata): ...to here. [source]: Replace 'string-append' by 'bioconductor-uri' with 'experiment.
-rw-r--r--gnu/packages/bioconductor.scm26
-rw-r--r--gnu/packages/bioinformatics.scm28
2 files changed, 26 insertions, 28 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b90e315267..b25cc8e019 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1170,6 +1170,32 @@ genomes and gene ID formats, largely based on the UCSC table browser.")
and visualize the results.")
(license license:gpl3)))
+(define-public r-genomationdata
+ (package
+ (name "r-genomationdata")
+ (version "1.22.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "genomationData" version 'experiment))
+ (sha256
+ (base32
+ "0igjsvfnws3498j65ifniw0kbxfqpfr59rcjddqvq4zsj453fx1g"))))
+ (properties
+ `((upstream-name . "genomationData")))
+ (build-system r-build-system)
+ ;; As this package provides little more than large data files, it doesn't
+ ;; make sense to build substitutes.
+ (arguments `(#:substitutable? #f))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioinformatics.mdc-berlin.de/genomation/")
+ (synopsis "Experimental data for use with the genomation package")
+ (description
+ "This package contains experimental genetic data for use with the
+genomation package. Included are Chip Seq, Methylation and Cage data,
+downloaded from Encode.")
+ (license license:gpl3+)))
+
(define-public r-pasilla
(package
(name "r-pasilla")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cc6e1b1594..1b94b62b1d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8023,34 +8023,6 @@ used to obtain robust estimates of the predominant fragment length or
characteristic tag shift values in these assays.")
(license license:bsd-3)))
-(define-public r-genomationdata
- (package
- (name "r-genomationdata")
- (version "1.22.0")
- (source (origin
- (method url-fetch)
- ;; We cannot use bioconductor-uri here because this tarball is
- ;; located under "data/annotation/" instead of "bioc/".
- (uri (string-append "https://bioconductor.org/packages/"
- "release/data/experiment/src/contrib/"
- "genomationData_" version ".tar.gz"))
- (sha256
- (base32
- "0igjsvfnws3498j65ifniw0kbxfqpfr59rcjddqvq4zsj453fx1g"))))
- (build-system r-build-system)
- ;; As this package provides little more than large data files, it doesn't
- ;; make sense to build substitutes.
- (arguments `(#:substitutable? #f))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioinformatics.mdc-berlin.de/genomation/")
- (synopsis "Experimental data for use with the genomation package")
- (description
- "This package contains experimental genetic data for use with the
-genomation package. Included are Chip Seq, Methylation and Cage data,
-downloaded from Encode.")
- (license license:gpl3+)))
-
(define-public r-seqlogo
(package
(name "r-seqlogo")