summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:37:58 +0200
commitbb118f20fe6581a4acbd3799ed31ab0d21e72e78 (patch)
tree909d75a5a04bac2be89204262ad2acc5fbf21834
parent7756e08b44b40ff46357572befa81fb173ca7edc (diff)
downloadguix-patches-bb118f20fe6581a4acbd3799ed31ab0d21e72e78.tar
guix-patches-bb118f20fe6581a4acbd3799ed31ab0d21e72e78.tar.gz
gnu: r-aroma-light: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-aroma-light): Move from here... * gnu/packages/bioconductor.scm (r-aroma-light): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm27
-rw-r--r--gnu/packages/bioinformatics.scm27
2 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 8fc035b623..3f057a3a4d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,33 @@ annotation data packages using SQLite data storage.")
databases. Packages produced are intended to be used with AnnotationDbi.")
(license license:artistic2.0)))
+(define-public r-aroma-light
+ (package
+ (name "r-aroma-light")
+ (version "3.20.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "aroma.light" version))
+ (sha256
+ (base32
+ "0pi37rlfqh24p9wd7l1xb3f7c7938xdscgcc5agp8c9qhajq25a0"))))
+ (properties `((upstream-name . "aroma.light")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrixstats" ,r-matrixstats)
+ ("r-r-methodss3" ,r-r-methodss3)
+ ("r-r-oo" ,r-r-oo)
+ ("r-r-utils" ,r-r-utils)))
+ (home-page "https://github.com/HenrikBengtsson/aroma.light")
+ (synopsis "Methods for normalization and visualization of microarray data")
+ (description
+ "This package provides methods for microarray analysis that take basic
+data types such as matrices and lists of vectors. These methods can be used
+standalone, be utilized in other packages, or be wrapped up in higher-level
+classes.")
+ (license license:gpl2+)))
+
(define-public r-biobase
(package
(name "r-biobase")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f6ec7e32c4..687da8086e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9196,33 +9196,6 @@ their variance is independent of the mean, and they are usually more sensitive
and specific in detecting differential transcription.")
(license license:artistic2.0)))
-(define-public r-aroma-light
- (package
- (name "r-aroma-light")
- (version "3.20.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "aroma.light" version))
- (sha256
- (base32
- "0pi37rlfqh24p9wd7l1xb3f7c7938xdscgcc5agp8c9qhajq25a0"))))
- (properties `((upstream-name . "aroma.light")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-matrixstats" ,r-matrixstats)
- ("r-r-methodss3" ,r-r-methodss3)
- ("r-r-oo" ,r-r-oo)
- ("r-r-utils" ,r-r-utils)))
- (home-page "https://github.com/HenrikBengtsson/aroma.light")
- (synopsis "Methods for normalization and visualization of microarray data")
- (description
- "This package provides methods for microarray analysis that take basic
-data types such as matrices and lists of vectors. These methods can be used
-standalone, be utilized in other packages, or be wrapped up in higher-level
-classes.")
- (license license:gpl2+)))
-
(define-public r-deseq
(package
(name "r-deseq")