summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:37:57 +0200
commitad46c8aa7f8ae74aa8f594b4cd663ea2ea9a8115 (patch)
treef8213eed4094069e8cfac1398aa5aa6c1a591c29
parentd7fa9c1ffdbd0ab4d4412020c925be39503ce9e8 (diff)
downloadguix-patches-ad46c8aa7f8ae74aa8f594b4cd663ea2ea9a8115.tar
guix-patches-ad46c8aa7f8ae74aa8f594b4cd663ea2ea9a8115.tar.gz
gnu: r-pcamethods: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-pcamethods): Move from here... * gnu/packages/bioconductor.scm (r-pcamethods): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm30
-rw-r--r--gnu/packages/bioinformatics.scm30
2 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b25cc8e019..e70f2bc13d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2731,6 +2731,36 @@ contains a number of utilities to explore the MS/MS results and assess missed
and irregular enzymatic cleavages, mass measurement accuracy, etc.")
(license license:artistic2.0)))
+(define-public r-pcamethods
+ (package
+ (name "r-pcamethods")
+ (version "1.82.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "pcaMethods" version))
+ (sha256
+ (base32
+ "04xb4vjky6hq58l30i1iq9rv5gzjdxnidjxpnzg7pvg67vz8pgf0"))))
+ (properties `((upstream-name . "pcaMethods")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-mass" ,r-mass)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/hredestig/pcamethods")
+ (synopsis "Collection of PCA methods")
+ (description
+ "This package provides Bayesian PCA, Probabilistic PCA, Nipals PCA,
+Inverse Non-Linear PCA and the conventional SVD PCA. A cluster based method
+for missing value estimation is included for comparison. BPCA, PPCA and
+NipalsPCA may be used to perform PCA on incomplete data as well as for
+accurate missing value estimation. A set of methods for printing and plotting
+the results is also provided. All PCA methods make use of the same data
+structure (pcaRes) to provide a common interface to the PCA results.")
+ (license license:gpl3+)))
+
(define-public r-rbgl
(package
(name "r-rbgl")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1b94b62b1d..a2c99ecbd6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9227,36 +9227,6 @@ mzIdentML files with the drawback of having less pretty output than a vendor
specific parser.")
(license license:gpl2+)))
-(define-public r-pcamethods
- (package
- (name "r-pcamethods")
- (version "1.82.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "pcaMethods" version))
- (sha256
- (base32
- "04xb4vjky6hq58l30i1iq9rv5gzjdxnidjxpnzg7pvg67vz8pgf0"))))
- (properties `((upstream-name . "pcaMethods")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biobase" ,r-biobase)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-mass" ,r-mass)
- ("r-rcpp" ,r-rcpp)))
- (home-page "https://github.com/hredestig/pcamethods")
- (synopsis "Collection of PCA methods")
- (description
- "This package provides Bayesian PCA, Probabilistic PCA, Nipals PCA,
-Inverse Non-Linear PCA and the conventional SVD PCA. A cluster based method
-for missing value estimation is included for comparison. BPCA, PPCA and
-NipalsPCA may be used to perform PCA on incomplete data as well as for
-accurate missing value estimation. A set of methods for printing and plotting
-the results is also provided. All PCA methods make use of the same data
-structure (pcaRes) to provide a common interface to the PCA results.")
- (license license:gpl3+)))
-
(define-public r-aroma-light
(package
(name "r-aroma-light")