summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:34:45 +0200
commita2a1d86a77b513dc2d49f6ae8735f2e3d9e2f8c0 (patch)
treef51b20ca2465de27d4fc64b25f090b8f85454a9c
parent4f030cc0db4806def4bb434817daee0e6c1cfa7d (diff)
downloadguix-patches-a2a1d86a77b513dc2d49f6ae8735f2e3d9e2f8c0.tar
guix-patches-a2a1d86a77b513dc2d49f6ae8735f2e3d9e2f8c0.tar.gz
gnu: r-samr: Move to (gnu packages bioconductor).
* gnu/packages/cran.scm (r-samr): Move from here... * gnu/packages/bioconductor.scm (r-samr): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm31
-rw-r--r--gnu/packages/cran.scm30
2 files changed, 31 insertions, 30 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0db6590be3..9c6ba94838 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
+;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2809,6 +2810,36 @@ built-in). The user may export/import tracks to/from the supported browsers,
as well as query and modify the browser state, such as the current viewport.")
(license license:artistic2.0)))
+;; This is a CRAN package, but it depends on a Bioconductor package.
+(define-public r-samr
+ (package
+ (name "r-samr")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "samr" version))
+ (sha256
+ (base32
+ "01km0f7qgm73x19vbvsxl083hs1dq4dj8qm5h64cxbf20b08my15"))))
+ (properties `((upstream-name . "samr")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gsa" ,r-gsa)
+ ("r-impute" ,r-impute)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-openxlsx" ,r-openxlsx)
+ ("r-shiny" ,r-shiny)
+ ("r-shinyfiles" ,r-shinyfiles)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://statweb.stanford.edu/~tibs/SAM/")
+ (synopsis "Significance analysis of Microarrays")
+ (description
+ "This is a package for significance analysis of Microarrays for
+differential expression analysis, RNAseq data and related problems.")
+ ;; Any version of the LGPL
+ (license license:lgpl3+)))
+
(define-public r-shortread
(package
(name "r-shortread")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 878980a230..711792958c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33,7 +33,6 @@
;;; Copyright © 2020 Magali Lemes <magalilemes00@gmail.com>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
-;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29153,35 +29152,6 @@ indicator, a quantitative variable or a survival time.")
;; Any version of the LGPL
(license license:lgpl3+)))
-(define-public r-samr
- (package
- (name "r-samr")
- (version "3.0")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "samr" version))
- (sha256
- (base32
- "01km0f7qgm73x19vbvsxl083hs1dq4dj8qm5h64cxbf20b08my15"))))
- (properties `((upstream-name . "samr")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-gsa" ,r-gsa)
- ("r-impute" ,r-impute)
- ("r-matrixstats" ,r-matrixstats)
- ("r-openxlsx" ,r-openxlsx)
- ("r-shiny" ,r-shiny)
- ("r-shinyfiles" ,r-shinyfiles)))
- (native-inputs `(("gfortran" ,gfortran)))
- (home-page "https://statweb.stanford.edu/~tibs/SAM/")
- (synopsis "Significance analysis of Microarrays")
- (description
- "This is a package for significance analysis of Microarrays for
-differential expression analysis, RNAseq data and related problems.")
- ;; Any version of the LGPL
- (license license:lgpl3+)))
-
(define-public r-randomforestsrc
(package
(name "r-randomforestsrc")