summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-03-24 20:23:15 +0100
committerCyril Roelandt <tipecaml@gmail.com>2013-03-24 20:23:15 +0100
commita25fe6d62069ffaff276bf1747ab178441654f9d (patch)
treebccc0067f04327c199fab75654221e565ec7f760
parentd539646af4bdb07abcea2e0f57eb9c50131197ab (diff)
downloadguix-patches-a25fe6d62069ffaff276bf1747ab178441654f9d.tar
guix-patches-a25fe6d62069ffaff276bf1747ab178441654f9d.tar.gz
gnu: add dependencies to poppler.
Add libpng and zlib to the inputs.
-rw-r--r--gnu/packages/pdf.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 5a9d513336..a172414553 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -25,6 +25,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages libpng)
#:use-module (gnu packages libtiff)
#:use-module (gnu packages pkg-config))
@@ -40,15 +41,25 @@
"1rmrspavldlpqi6g76fijcmshy80m0kxd01nc1dmy4id3h4las44"))))
(build-system gnu-build-system)
;; FIXME: more dependencies could be added
+ ;; cairo output: no (requires cairo >= 1.10.0)
+ ;; qt4 wrapper: no
+ ;; glib wrapper: no (requires cairo output)
+ ;; introspection: no
+ ;; use gtk-doc: no
+ ;; use libcurl: no
+ ;; use libopenjpeg: no
(inputs `(("fontconfig" ,fontconfig)
("freetype" ,freetype)
("libjpeg-8" ,libjpeg-8)
+ ("libpng" ,libpng)
("libtiff" ,libtiff)
("pkg-config" ,pkg-config)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ; no test data provided with the tarball
- #:configure-flags '("--enable-xpdf-headers"))) ; to install header files
+ #:configure-flags
+ '("--enable-xpdf-headers" ; to install header files
+ "--enable-zlib")))
(synopsis "Poppler, a pdf rendering library")
(description
"Poppler is a PDF rendering library based on the xpdf-3.0 code base.")