summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 13:08:32 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:07:39 +0200
commit9c7f15c048636fcba8f64f6e257482a01396ae6f (patch)
tree9aab5031439173985c2d2ce9e3585b69ee6dd362
parent6f2c4efb56520f8f63ee7f15f694f5582b4d04c4 (diff)
downloadguix-patches-9c7f15c048636fcba8f64f6e257482a01396ae6f.tar
guix-patches-9c7f15c048636fcba8f64f6e257482a01396ae6f.tar.gz
gnu: Add ruby-colorator.
* gnu/packages/ruby.scm (ruby-colorator): New variable.
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 862193f305..90af1481c9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5144,3 +5144,23 @@ all known public suffixes.")
is part of Ruby's standard library. It more closely conforms to RFC 3986,
RFC 3987, and RFC 6570 (level 4), providing support for IRIs and URI templates.")
(license license:asl2.0)))
+
+(define-public ruby-colorator
+ (package
+ (name "ruby-colorator")
+ (version "1.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "colorator" version))
+ (sha256
+ (base32
+ "0f7wvpam948cglrciyqd798gdc6z3cfijciavd0dfixgaypmvy72"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; No test target
+ `(#:tests? #f))
+ (home-page "http://octopress.org/colorator/")
+ (synopsis "Terminal color library")
+ (description "Colorator is a Ruby gem that helps you colorize your text
+for the terminal.")
+ (license license:expat)))