summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-01 22:29:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-02 21:29:52 +0100
commit9775d22f8c866eb263c4f13ba23c2471ea4f75f1 (patch)
tree4800f2555b7910b2ba55dc2114c7d21291ce3e07
parent87e57cbecbd166c549283224a28a5c68d2a9800c (diff)
downloadguix-patches-9775d22f8c866eb263c4f13ba23c2471ea4f75f1.tar
guix-patches-9775d22f8c866eb263c4f13ba23c2471ea4f75f1.tar.gz
gnu: Add naev.
* gnu/packages/games.scm (naev): New variable.
-rw-r--r--gnu/packages/games.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 782c2b9c2e..42753dc1a4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8036,6 +8036,66 @@ ncurses for text display.")
(home-page "http://frotz.sourceforge.net")
(license license:gpl2+)))
+(define-public naev
+ (package
+ (name "naev")
+ (version "0.8.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/naev/naev")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02rk2fv2nhx5xsi0cariisamab3dpncwps4q3i3ki0y27xpwxzfx"))))
+ (build-system meson-build-system)
+ (arguments
+ ;; XXX: Do not add debugging symbols, which cause the build to fail.
+ `(#:configure-flags (list "--buildtype=release")
+ #:tests? #f ;sole test fails with a missing "/dev/dri" error
+ #:meson ,meson-0.55))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("glpk" ,glpk)
+ ("libpng" ,libpng)
+ ("libvorbis" ,libvorbis)
+ ("libwebp" ,libwebp)
+ ("libxml2" ,libxml2)
+ ("luajit" ,luajit)
+ ("openal" ,openal)
+ ("openblas" ,openblas)
+ ("physfs" ,physfs)
+ ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer)))
+ ("suitesparse" ,suitesparse)))
+ (home-page "https://naev.org/")
+ (synopsis "Game about space exploration, trade and combat")
+ (description
+ "Naev is a 2d action/rpg space game that combines elements from
+the action, RPG and simulation genres. You pilot a spaceship from
+a top-down perspective, and are more or less free to do what you want.
+As the genre name implies, you’re able to trade and engage in combat
+at will. Beyond that, there’s an ever-growing number of story-line
+missions, equipment, and ships; even the galaxy itself grows larger
+with each release. For the literacy-inclined, there are large amounts
+of lore accompanying everything from planets to equipment.")
+ (license (list license:gpl3
+ license:public-domain
+ license:expat ;edtaa3func.c
+ license:bsd-2 ;distance_field.c
+ license:bsd-3 ;perlin.c
+ ;; Assets.
+ license:silofl1.1
+ license:gpl2+
+ license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0
+ license:cc-by4.0
+ license:cc-by-sa4.0))))
+
(define-public frotz-dumb-terminal
(package
(name "frotz-dumb-terminal")