summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 13:10:06 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:07:42 +0200
commit78b9c291f6d656e2912f59b9eaf8dfaca925ea94 (patch)
tree07627fee7c77b97aac6f3d4d4cb04e008e46d597
parent9c7f15c048636fcba8f64f6e257482a01396ae6f (diff)
downloadguix-patches-78b9c291f6d656e2912f59b9eaf8dfaca925ea94.tar
guix-patches-78b9c291f6d656e2912f59b9eaf8dfaca925ea94.tar.gz
gnu: Add ruby-command-line-reporter.
* gnu/packages/ruby.scm (ruby-command-line-reporter): New variable.
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 90af1481c9..7dab7b834f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5164,3 +5164,36 @@ RFC 3987, and RFC 6570 (level 4), providing support for IRIs and URI templates."
(description "Colorator is a Ruby gem that helps you colorize your text
for the terminal.")
(license license:expat)))
+
+(define-public ruby-command-line-reporter
+ (package
+ (name "ruby-command-line-reporter")
+ (version "4.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "command_line_reporter" version))
+ (sha256
+ (base32
+ "1qma35xrb772whxwy1rs9bicb9d6lvz0s2dd2dnn4fr6zcbcxc0a"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; No Rakefile
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-dependencies
+ (lambda _
+ (substitute* ".gemspec"
+ ;; colored is unmaintained
+ (("colored") "colorator")
+ ;; colorator version
+ (("= 1.2") "= 1.1"))
+ #t)))))
+ (propagated-inputs `(("ruby-colorator" ,ruby-colorator)))
+ (home-page "https://github.com/wbailey/command_line_reporter")
+ (synopsis "Report production while executing Ruby scripts")
+ (description "This gem provides a DSL that makes it easy to write reports
+of various types in ruby. It eliminates the need to litter your source with
+puts statements, instead providing a more readable, expressive interface to
+your application.")
+ (license license:asl2.0)))