summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-20 11:11:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-02-01 11:34:00 +0200
commit73d93343baa43733bf1fecc23bcb1f36a78ef615 (patch)
tree732ccd10298101c6bceb1022a87ecf5a5e3d8f97
parent264162124f814470e06e419ea464b6c6bb9b0a3d (diff)
downloadguix-patches-73d93343baa43733bf1fecc23bcb1f36a78ef615.tar
guix-patches-73d93343baa43733bf1fecc23bcb1f36a78ef615.tar.gz
gnu: libaio: Fix test suite on riscv64-linux.
* gnu/packages/linux.scm (libaio)[arguments]: Add phase to adjust test code to properly handle riscv.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 15aed1eefe..4d3ff8efd4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5263,7 +5263,19 @@ Linux Device Mapper multipathing driver:
#:test-target "partcheck" ; need root for a full 'check'
#:phases
#~(modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (delete 'configure) ; no configure script
+ ;; TODO: Make this phase unconditional on core-updates.
+ #$@(if (target-riscv64?)
+ '((add-before 'check 'patch-for-riscv-support
+ (lambda _
+ ;; Taken from the upstream repo:
+ ;; https://pagure.io/libaio/c/f322f467c3cd2ac4d8d08a19bd281eabb65433b1?branch=master
+ (substitute* "harness/cases/16.t"
+ (("(elif defined\\(__aarch64__\\))" all)
+ (string-append all " || defined(__riscv)"))
+ (("(endif /* __aarch64__)" all)
+ (string-append all " || __riscv "))))))
+ '()))))
(home-page "https://pagure.io/libaio")
(synopsis "Linux-native asynchronous I/O access library")
(description