summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:38:00 +0200
commit720d2694a5e50fac5d86f67a5faae61881ad4b38 (patch)
tree11db666310bc295b60df00ba0ce9d2266c45ab1e
parent88cf24febb43768c780d55cd496034d227096550 (diff)
downloadguix-patches-720d2694a5e50fac5d86f67a5faae61881ad4b38.tar
guix-patches-720d2694a5e50fac5d86f67a5faae61881ad4b38.tar.gz
gnu: r-mzr: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-mzr): Move from here... * gnu/packages/bioconductor.scm (r-mzr): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm62
-rw-r--r--gnu/packages/bioinformatics.scm61
2 files changed, 62 insertions, 61 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index eb0bcb22c6..08d4545257 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages bioinformatics)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages cran)
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
@@ -3256,6 +3257,67 @@ mzIdentML files with the drawback of having less pretty output than a vendor
specific parser.")
(license license:gpl2+)))
+(define-public r-mzr
+ (package
+ (name "r-mzr")
+ (version "2.24.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "mzR" version))
+ (sha256
+ (base32
+ "0ik0yrjhvk8r5pm990chn2aadp0gqzzkkm0027682ky34xp142sg"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "src/boost")
+ #t))))
+ (properties `((upstream-name . "mzR")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-system-boost
+ (lambda _
+ (substitute* "src/Makevars"
+ (("\\./boost/libs.*") "")
+ ;; This is to avoid having a plain directory on the list of
+ ;; libraries to link.
+ (("\\(RHDF5_LIBS\\)" match)
+ (string-append match "/libhdf5.a"))
+ (("PKG_LIBS=") "PKG_LIBS=$(BOOST_LIBS) ")
+ (("\\ARCH_OBJS=" line)
+ (string-append line
+ "\nBOOST_LIBS=-lboost_system -lboost_regex \
+-lboost_iostreams -lboost_thread -lboost_filesystem -lboost_chrono\n")))
+ #t)))))
+ (inputs
+ `(;; Our default boost package won't work here, unfortunately, even with
+ ;; mzR version 2.24.1.
+ ("boost" ,boost-for-mysql) ; use this instead of the bundled boost sources
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-ncdf4" ,r-ncdf4)
+ ("r-protgenerics" ,r-protgenerics)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rhdf5lib" ,r-rhdf5lib)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/sneumann/mzR/")
+ (synopsis "Parser for mass spectrometry data files")
+ (description
+ "The mzR package provides a unified API to the common file formats and
+parsers available for mass spectrometry data. It comes with a wrapper for the
+ISB random access parser for mass spectrometry mzXML, mzData and mzML files.
+The package contains the original code written by the ISB, and a subset of the
+proteowizard library for mzML and mzIdentML. The netCDF reading code has
+previously been used in XCMS.")
+ (license license:artistic2.0)))
+
(define-public r-organismdbi
(package
(name "r-organismdbi")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4be61522b6..b356a76681 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9047,67 +9047,6 @@ trait.")
proteomics packages.")
(license license:artistic2.0)))
-(define-public r-mzr
- (package
- (name "r-mzr")
- (version "2.24.1")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "mzR" version))
- (sha256
- (base32
- "0ik0yrjhvk8r5pm990chn2aadp0gqzzkkm0027682ky34xp142sg"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "src/boost")
- #t))))
- (properties `((upstream-name . "mzR")))
- (build-system r-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'use-system-boost
- (lambda _
- (substitute* "src/Makevars"
- (("\\./boost/libs.*") "")
- ;; This is to avoid having a plain directory on the list of
- ;; libraries to link.
- (("\\(RHDF5_LIBS\\)" match)
- (string-append match "/libhdf5.a"))
- (("PKG_LIBS=") "PKG_LIBS=$(BOOST_LIBS) ")
- (("\\ARCH_OBJS=" line)
- (string-append line
- "\nBOOST_LIBS=-lboost_system -lboost_regex \
--lboost_iostreams -lboost_thread -lboost_filesystem -lboost_chrono\n")))
- #t)))))
- (inputs
- `(;; Our default boost package won't work here, unfortunately, even with
- ;; mzR version 2.24.1.
- ("boost" ,boost-for-mysql) ; use this instead of the bundled boost sources
- ("zlib" ,zlib)))
- (propagated-inputs
- `(("r-biobase" ,r-biobase)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-ncdf4" ,r-ncdf4)
- ("r-protgenerics" ,r-protgenerics)
- ("r-rcpp" ,r-rcpp)
- ("r-rhdf5lib" ,r-rhdf5lib)
- ("r-zlibbioc" ,r-zlibbioc)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://github.com/sneumann/mzR/")
- (synopsis "Parser for mass spectrometry data files")
- (description
- "The mzR package provides a unified API to the common file formats and
-parsers available for mass spectrometry data. It comes with a wrapper for the
-ISB random access parser for mass spectrometry mzXML, mzData and mzML files.
-The package contains the original code written by the ISB, and a subset of the
-proteowizard library for mzML and mzIdentML. The netCDF reading code has
-previously been used in XCMS.")
- (license license:artistic2.0)))
-
(define-public r-dropbead
(let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
(revision "2"))