summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:38:00 +0200
commit621aa3b442341c81305d2d56835203ff517a7bb9 (patch)
treefc9d8cf290325f1ce50f50c7685a2db80f9fae98
parent900ef8fb1ea8a85966a1a81ea01a9f3670fc8c58 (diff)
downloadguix-patches-621aa3b442341c81305d2d56835203ff517a7bb9.tar
guix-patches-621aa3b442341c81305d2d56835203ff517a7bb9.tar.gz
gnu: r-sva: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-sva): Move from here... * gnu/packages/bioconductor.scm (r-sva): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm31
-rw-r--r--gnu/packages/bioinformatics.scm31
2 files changed, 31 insertions, 31 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 8e0182691b..a4d99dd929 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3790,6 +3790,37 @@ typically represent genomic ranges of interest and the columns represent
samples.")
(license license:artistic2.0)))
+(define-public r-sva
+ (package
+ (name "r-sva")
+ (version "3.38.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "sva" version))
+ (sha256
+ (base32
+ "1hpzzg3qrgkd8kwg1m5gq94cikjgk9j4l1wk58fxl49s6fmd13zy"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-edger" ,r-edger)
+ ("r-genefilter" ,r-genefilter)
+ ("r-mgcv" ,r-mgcv)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-limma" ,r-limma)))
+ (home-page "https://bioconductor.org/packages/sva")
+ (synopsis "Surrogate variable analysis")
+ (description
+ "This package contains functions for removing batch effects and other
+unwanted variation in high-throughput experiment. It also contains functions
+for identifying and building surrogate variables for high-dimensional data
+sets. Surrogate variables are covariates constructed directly from
+high-dimensional data like gene expression/RNA sequencing/methylation/brain
+imaging data that can be used in subsequent analyses to adjust for unknown,
+unmodeled, or latent sources of noise.")
+ (license license:artistic2.0)))
+
(define-public r-systempiper
(package
(name "r-systempiper")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ca0952895c..cb0fe505cb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8964,37 +8964,6 @@ resolution 5hmC data from experimental protocols such as oxBS-Seq and
TAB-Seq.")
(license license:artistic2.0)))
-(define-public r-sva
- (package
- (name "r-sva")
- (version "3.38.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "sva" version))
- (sha256
- (base32
- "1hpzzg3qrgkd8kwg1m5gq94cikjgk9j4l1wk58fxl49s6fmd13zy"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-edger" ,r-edger)
- ("r-genefilter" ,r-genefilter)
- ("r-mgcv" ,r-mgcv)
- ("r-biocparallel" ,r-biocparallel)
- ("r-matrixstats" ,r-matrixstats)
- ("r-limma" ,r-limma)))
- (home-page "https://bioconductor.org/packages/sva")
- (synopsis "Surrogate variable analysis")
- (description
- "This package contains functions for removing batch effects and other
-unwanted variation in high-throughput experiment. It also contains functions
-for identifying and building surrogate variables for high-dimensional data
-sets. Surrogate variables are covariates constructed directly from
-high-dimensional data like gene expression/RNA sequencing/methylation/brain
-imaging data that can be used in subsequent analyses to adjust for unknown,
-unmodeled, or latent sources of noise.")
- (license license:artistic2.0)))
-
(define-public r-raremetals2
(package
(name "r-raremetals2")