summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Pelz <pelzflorian@pelzflorian.de>2019-06-02 20:01:23 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-03 23:18:46 +0200
commit1acd107c6b0e5613bc001347945d7c3f00e3157b (patch)
treef14e7731abd66e4eec4cc670eec7553b91dc91b6
parent27faad22a8714c2bf83fb6e78b931545586dd46c (diff)
downloadguix-patches-1acd107c6b0e5613bc001347945d7c3f00e3157b.tar
guix-patches-1acd107c6b0e5613bc001347945d7c3f00e3157b.tar.gz
gnu: gnome-control-center: Set correct file name for the 'passwd' binary.
* gnu/packages/gnome.scm (gnome-control-center): Substitute correct path to passwd. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 561936f164..d6f9f71db8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5881,6 +5881,9 @@ devices using the GNOME desktop.")
(("\"nm-connection-editor")
(string-append "\"" nm-applet
"/bin/nm-connection-editor")))
+ (substitute* '("panels/user-accounts/run-passwd.c")
+ (("/usr/bin/passwd")
+ "/run/setuid-programs/passwd"))
#t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.