summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 13:43:30 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:07:48 +0200
commit18077ffc4613be27d087eb4d3dadd5cdf189cd74 (patch)
treef7fa1f83e90aa04b03019041bf024afabfea6d30
parent6bba8ecf7b9a087d405d30373bd18a5e524f4918 (diff)
downloadguix-patches-18077ffc4613be27d087eb4d3dadd5cdf189cd74.tar
guix-patches-18077ffc4613be27d087eb4d3dadd5cdf189cd74.tar.gz
gnu: Add ruby-sass-listen.
* gnu/packages/ruby.scm (ruby-sass-listen): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cd88ea921c..60869be9b8 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5229,3 +5229,26 @@ your application.")
projects. RDoc includes the +rdoc+ and +ri+ tools for generating and displaying
documentation from the command-line.")
(license license:gpl2+)))
+
+(define-public ruby-sass-listen
+ (package
+ (name "ruby-sass-listen")
+ (version "4.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "sass-listen" version))
+ (sha256
+ (base32
+ "0xw3q46cmahkgyldid5hwyiwacp590zj2vmswlll68ryvmvcp7df"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; No test target
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-rb-fsevent" ,ruby-rb-fsevent)
+ ("ruby-rb-inotify" ,ruby-rb-inotify)))
+ (home-page "https://github.com/sass/listen")
+ (synopsis "File modification notification library")
+ (description "The Listen gem listens to file modifications and notifies you
+about the changes.")
+ (license license:expat)))