summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-12-14 13:00:20 -0500
committerLudovic Courtès <ludo@gnu.org>2020-12-21 17:47:35 +0100
commit25b2d83d007e83d980c39cd09c38c641120e4366 (patch)
tree05fd50e9a50c2d0d6ac55fd00f7b9b7aa46046fe
parent29e91f0a618b6ffa33ae1321caa321f87948ea25 (diff)
downloadguix-patches-25b2d83d007e83d980c39cd09c38c641120e4366.tar
guix-patches-25b2d83d007e83d980c39cd09c38c641120e4366.tar.gz
gnu: sdcc: Remove bundled μCsim.
* gnu/packages/sdcc.scm (sdcc)[source]: Extend snippet to remove bundled μCsim source. [arguments]<#:configure-flags>: Replace "--enable-ucsim" with "--disable-ucsim". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/sdcc.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/sdcc.scm b/gnu/packages/sdcc.scm
index aad2cf9e62..0ce71ed955 100644
--- a/gnu/packages/sdcc.scm
+++ b/gnu/packages/sdcc.scm
@@ -46,6 +46,8 @@
'(begin
;; Remove non-free source files
(delete-file-recursively "device/non-free")
+ ;; Remove bundled μCsim source
+ (delete-file-recursively "sim")
#t))
(patches (search-patches "sdcc-disable-non-free-code.patch"))))
(build-system gnu-build-system)
@@ -58,7 +60,7 @@
(arguments
`(;; gputils is required for PIC ports
#:configure-flags
- '("--disable-pic14-port" "--disable-pic16-port" "--enable-ucsim")
+ '("--disable-pic14-port" "--disable-pic16-port" "--disable-ucsim")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-makefile