summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-14 18:38:11 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-06-08 23:19:38 +0300
commitda23cc000e6c85f8590e7cf2bc57e3e9f1b4a78f (patch)
tree2be8a4de3ffa69f7b32459aa97219c0414c8c917
parentc315d3705821ae5c3d15a35a2c83bd870901e906 (diff)
downloadguix-patches-da23cc000e6c85f8590e7cf2bc57e3e9f1b4a78f.tar
guix-patches-da23cc000e6c85f8590e7cf2bc57e3e9f1b4a78f.tar.gz
gnu: Add emacs-ivy-yasnippet.
* gnu/packages/emacs.scm (emacs-ivy-yasnippet): New public variable.
-rw-r--r--gnu/packages/emacs.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b7288161dc..d115f0387f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3643,6 +3643,35 @@ splitting the input text by spaces and re-building it into a regular
expression.")
(license license:gpl3+)))
+(define-public emacs-ivy-yasnippet
+ (let ((commit "59b32cf8cfb63df906822a17f6f5e8545dac38d4"))
+ (package
+ (name "emacs-ivy-yasnippet")
+ (version (git-version "0.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mkcms/ivy-yasnippet.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hghdlxkfwrglvc1nql2ikgp6jj0qdbfwc3yvpb19mrf26hwgp13"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ivy" ,emacs-ivy)
+ ("emacs-yasnippet" ,emacs-yasnippet)
+ ("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/mkcms/ivy-yasnippet")
+ (synopsis "Preview @code{yasnippets} with @code{ivy}")
+ (description "This package allows you to select @code{yasnippet}
+snippets using @code{ivy} completion. When current selection changes in the
+minibuffer, the snippet contents are temporarily expanded in the buffer. To
+use it, call @code{M-x ivy-yasnippet} (but make sure you have enabled
+@code{yas-minor-mode} first).")
+ (license license:gpl3+))))
+
(define-public emacs-avy
(package
(name "emacs-avy")