summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-01-22 23:48:08 +0100
committerAndreas Enge <andreas@enge.fr>2013-01-22 23:48:08 +0100
commit2b902c3c467257f61b9d5e52739b052d8ecd32ee (patch)
treed812197c63017defb856022dbba2e042c6cc3307
parent67668155c5b3c4c37717404aa73f7224fced1d81 (diff)
downloadguix-patches-2b902c3c467257f61b9d5e52739b052d8ecd32ee.tar
guix-patches-2b902c3c467257f61b9d5e52739b052d8ecd32ee.tar.gz
gnu: ghostscript: Build and install shared library and header files.
* gnu/packages/ghostscript (ghostscript): Extend build and install phases.
-rw-r--r--gnu/packages/ghostscript.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index f5ca71313d..472ada47b1 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -150,7 +150,19 @@ printing, and psresize, for adjusting page sizes.")
(("/bin/sh") (which "bash")))
(substitute* "base/unixhead.mak"
(("/bin/sh") (which "bash")))))
- %standard-phases)))
+ (alist-replace
+ 'build
+ (lambda* (#:key #:allow-other-keys #:rest args)
+ (let ((build (assoc-ref %standard-phases 'build)))
+ (apply build args)
+ (system* "make" "so")))
+ (alist-replace
+ 'install
+ (lambda* (#:key #:allow-other-keys #:rest args)
+ (let ((install (assoc-ref %standard-phases 'install)))
+ (apply install args)
+ (system* "make" "install-so")))
+ %standard-phases)))))
(synopsis "GNU Ghostscript, an interpreter for the PostScript language and for PDF")
(description
"GNU Ghostscript is an interpreter for PostScript and Portable Document