summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-15 21:56:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-29 00:54:52 +0200
commit19c0280ff7f77d4ed641dd04382b02d4cae0a9ab (patch)
tree35b2efdd6d8caac832a207a1ad50449c7b00ba62
parent93c47bff5d90655d462a8451b1d83265a1beb6b4 (diff)
downloadguix-patches-19c0280ff7f77d4ed641dd04382b02d4cae0a9ab.tar
guix-patches-19c0280ff7f77d4ed641dd04382b02d4cae0a9ab.tar.gz
gnu: Add burgerspace.
* gnu/packages/games.scm (burgerspace): New variable.
-rw-r--r--gnu/packages/games.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f5a410f2c3..8beb8cd2e3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10881,6 +10881,33 @@ soldiers, jeeps and tanks. The gameplay is simple but it is not that easy to
get high scores.")
(license license:gpl2+)))
+(define-public burgerspace
+ (package
+ (name "burgerspace")
+ (version "1.9.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://perso.b2b2c.ca/~sarrazip/dev/"
+ "burgerspace-" version ".tar.gz"))
+ (sha256
+ (base32 "1005a04rbn4lzjrpfg0m394k2mfaji63fm2qhdqdsxila8a6kjbv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("flatzebra" ,flatzebra)))
+ (home-page "http://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html")
+ (synopsis "Avoid evil foodstuffs and make burgers")
+ (description
+ "This is a clone of the classic game BurgerTime. In it, you play
+the part of a chef who must create burgers by stepping repeatedly on
+the ingredients until they fall into place. And to make things more
+complicated, you also must avoid evil animate food items while
+performing this task, with nothing but your trusty pepper shaker to
+protect you.")
+ (license license:gpl2+)))
+
(define-public 7kaa
(package
(name "7kaa")