summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-24 12:18:24 -0400
committerLeo Famulari <leo@famulari.name>2017-10-24 13:10:35 -0400
commit1899ef0b838075d82b957a632ce995f4e192849f (patch)
treea93864b92d0d52d9c75c9d106e1888af117b2469
parentc10851cf912d60d18d79badbbefe85c2d21081f9 (diff)
downloadguix-patches-1899ef0b838075d82b957a632ce995f4e192849f.tar
guix-patches-1899ef0b838075d82b957a632ce995f4e192849f.tar.gz
gnu: syncthing: Use install-source? to disable installing the source code.
* gnu/packages/syncthing.scm (syncthing): Set #:install-source? #f instead of deleting the install-source phase.
-rw-r--r--gnu/packages/syncthing.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index b4bc1e0a8a..0bfa6d9e07 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -41,6 +41,8 @@
(arguments
`(#:import-path "github.com/syncthing/syncthing"
#:unpack-path "github.com/syncthing"
+ ;; We don't need to install the source code for end-user applications.
+ #:install-source? #f
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'delete-bundled-source-code
@@ -55,9 +57,6 @@
"src/github.com/syncthing/syncthing/vendor/github.com/cznic")
#t))
- ;; We don't need to install the source code for end-user applications.
- (delete 'install-source)
-
(add-before 'build 'increase-test-timeout
(lambda _
(substitute* "src/github.com/syncthing/syncthing/build.go"