summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Ritter <chewzerita@posteo.net>2018-03-12 10:58:32 -0400
committerMarius Bakke <mbakke@fastmail.com>2018-03-26 21:43:58 +0200
commit948740b08a66a544754de31cc5746c89e9c2ff1d (patch)
treeb1bf5f7da1e718fae65ad64306686ef4f6d647e8
parent10487c30bca4047a07202ffea385e01e52ed6a51 (diff)
downloadguix-patches-948740b08a66a544754de31cc5746c89e9c2ff1d.tar
guix-patches-948740b08a66a544754de31cc5746c89e9c2ff1d.tar.gz
gnu: Add r-reprex.
* gnu/packages/cran.scm (r-reprex): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b2db1af3fb..e3bcaf3fc9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37,6 +37,34 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages web))
+(define-public r-reprex
+ (package
+ (name "r-reprex")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "reprex" version))
+ (sha256
+ (base32
+ "105d9vsmqfilgpw8psfb2wyiz1hvcycvh4cqhb3ab37lm3rcavvs"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-callr" ,r-callr)
+ ("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-whisker" ,r-whisker)))
+ (home-page "https://github.com/tidyverse/reprex")
+ (synopsis "Prepare reproducible R code examples for sharing")
+ (description
+ "This package provides a convenience wrapper that uses the
+@code{rmarkdown} package to render small snippets of code to target formats
+that include both code and output. The goal is to encourage the sharing of
+small, reproducible, and runnable examples on code-oriented websites or email.
+@code{reprex} also extracts clean, runnable R code from various common formats,
+such as copy/paste from an R session.")
+ (license license:expat)))
+
(define-public r-callr
(package
(name "r-callr")