summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-03-01 13:34:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-03-01 14:55:55 +0200
commitd06fc008bdb86169d951721bbb4604948368d7c2 (patch)
tree0b900aff312151a9100ea5be29e7e10b7303889f
parente8ea01d9027e565118181a5fe691d2ae01b4529b (diff)
downloadguix-patches-d06fc008bdb86169d951721bbb4604948368d7c2.tar
guix-patches-d06fc008bdb86169d951721bbb4604948368d7c2.tar.gz
gnu: tiled: Use 'modify-phases'.
* gnu/packages/game-development.scm (tiled)[arguments]: Use 'modify-phases'.
-rw-r--r--gnu/packages/game-development.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 773c517079..0a58a7efa5 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -142,13 +142,12 @@ provide connectivity for client applications written in any language.")
("zlib" ,zlib)))
(arguments
'(#:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (system* "qmake"
- (string-append "PREFIX=" out))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (system* "qmake"
+ (string-append "PREFIX=" out))))))))
(home-page "http://www.mapeditor.org/")
(synopsis "Tile map editor")
(description