summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-29 14:36:01 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-29 15:01:20 -0800
commitaa5946edb20a10a245ea24082bee0e01265235f9 (patch)
treeefe9e1cfab9cd712cbdcf74459df5abbde2777a8
parentdaeb61f7a92a178b0ac4a5c11b62b962293517e5 (diff)
downloadguix-patches-aa5946edb20a10a245ea24082bee0e01265235f9.tar
guix-patches-aa5946edb20a10a245ea24082bee0e01265235f9.tar.gz
gnu: Remove python2-pil.
python2-pil is vulnerable to several security issues (CVE-2016-0740, CVE-2016-0775, and CVE-2016-2533). Fortunately, python2-pillow provides equivalent functionality, so this package can be cleanly removed. * gnu/packages/python.scm (python2-pil): Remove variable.
-rw-r--r--gnu/packages/python.scm61
1 files changed, 0 insertions, 61 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 812aeb0027..4f34537df6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4596,67 +4596,6 @@ converts incoming documents to Unicode and outgoing documents to UTF-8.")
(strip-python2-variant python-beautifulsoup4)))
(native-inputs `(("python2-setuptools" ,python2-setuptools)))))
-(define-public python2-pil
- (package
- (name "python2-pil")
- (version "1.1.7")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://effbot.org/downloads/Imaging-"
- version ".tar.gz"))
- (sha256
- (base32
- "04aj80jhfbmxqzvmq40zfi4z3cw6vi01m3wkk6diz3lc971cfnw9"))
- (modules '((guix build utils)))
- (snippet
- ;; Adapt to newer freetype. As the package is unmaintained upstream,
- ;; there is no use in creating a patch and reporting it.
- '(substitute* "_imagingft.c"
- (("freetype/")
- "freetype2/")))))
- (build-system python-build-system)
- (inputs
- `(("freetype" ,freetype)
- ("libjpeg" ,libjpeg)
- ("libtiff" ,libtiff)
- ("python-setuptools" ,python-setuptools)
- ("zlib" ,zlib)))
- (arguments
- ;; Only the fork python-pillow works with Python 3.
- `(#:python ,python-2
- #:tests? #f ; no check target
- #:phases
- (alist-cons-before
- 'build 'configure
- ;; According to README and setup.py, manual configuration is
- ;; the preferred way of "searching" for inputs.
- ;; lcms is not found, TCL_ROOT refers to the unavailable tkinter.
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jpeg (assoc-ref inputs "libjpeg"))
- (zlib (assoc-ref inputs "zlib"))
- (tiff (assoc-ref inputs "libtiff"))
- (freetype (assoc-ref inputs "freetype")))
- (substitute* "setup.py"
- (("JPEG_ROOT = None")
- (string-append "JPEG_ROOT = libinclude(\"" jpeg "\")"))
- (("ZLIB_ROOT = None")
- (string-append "ZLIB_ROOT = libinclude(\"" zlib "\")"))
- (("TIFF_ROOT = None")
- (string-append "TIFF_ROOT = libinclude(\"" tiff "\")"))
- (("FREETYPE_ROOT = None")
- (string-append "FREETYPE_ROOT = libinclude(\""
- freetype "\")")))))
- %standard-phases)))
- (home-page "http://www.pythonware.com/products/pil/")
- (synopsis "Python Imaging Library")
- (description "The Python Imaging Library (PIL) adds image processing
-capabilities to the Python interpreter.")
- (license (x11-style
- "file://README"
- "See 'README' in the distribution."))))
-
(define-public python2-cssutils
(package
(name "python2-cssutils")