summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:33:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:51 +0100
commitdcafcfb4fd41016124edd0b24b96214fc3848622 (patch)
treeddb3668cadc563d3637c3ed2952adbc9fdd0c5fb
parentc358b5d418a89e1946f291c4be7d460acc36985e (diff)
downloadguix-patches-dcafcfb4fd41016124edd0b24b96214fc3848622.tar
guix-patches-dcafcfb4fd41016124edd0b24b96214fc3848622.tar.gz
gnu: Add r-assertive-reflection.
* gnu/packages/cran.scm (r-assertive-reflection): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index faecbf52fc..a10d430b9e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9630,3 +9630,28 @@ packages.")
the properties of models. This is mainly for use by other package developers
who want to include run-time testing features in their own packages.")
(license license:gpl3+)))
+
+(define-public r-assertive-reflection
+ (package
+ (name "r-assertive-reflection")
+ (version "0.0-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.reflection" version))
+ (sha256
+ (base32
+ "19zmsbn00crfqm0kwd9ys5gv87xs3gi6wmlikrz9xiwzm7hp4dhj"))))
+ (properties
+ `((upstream-name . "assertive.reflection")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertive-base" ,r-assertive-base)))
+ (home-page "https://bitbucket.org/richierocks/assertive.reflection")
+ (synopsis "Assertions for checking the state of R")
+ (description
+ "This package provides a set of predicates and assertions for checking
+the state and capabilities of R, the operating system it is running on, and
+the IDE being used. This is mainly for use by other package developers who
+want to include run-time testing features in their own packages.")
+ (license license:gpl3+)))