summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:38:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:51 +0100
commit6d3702e5ced15dd7daacaad1b0754f2eeb7038ca (patch)
tree55955ead5cc85a5909b2cc5682fab26396d14ec1
parent66d0a0a70657e0036cce20d6efd94dc179ca7636 (diff)
downloadguix-patches-6d3702e5ced15dd7daacaad1b0754f2eeb7038ca.tar
guix-patches-6d3702e5ced15dd7daacaad1b0754f2eeb7038ca.tar.gz
gnu: Add r-assertive-data-us.
* gnu/packages/cran.scm (r-assertive-data-us): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 16540f33fe..8dfc303101 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9785,3 +9785,29 @@ packages.")
the properties of strings. This is mainly for use by other package developers
who want to include run-time testing features in their own packages.")
(license license:gpl3+)))
+
+(define-public r-assertive-data-us
+ (package
+ (name "r-assertive-data-us")
+ (version "0.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.data.us" version))
+ (sha256
+ (base32
+ "1bgspn0sccmp9z7s7djvdvprgxlyc5vrxznp4zfjb79kwvgn83hq"))))
+ (properties
+ `((upstream-name . "assertive.data.us")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertive-base" ,r-assertive-base)
+ ("r-assertive-strings" ,r-assertive-strings)))
+ (home-page "https://bitbucket.org/richierocks/assertive.data.us")
+ (synopsis "Assertions to check properties of strings")
+ (description
+ "This package provides a set of predicates and assertions for checking
+the properties of US-specific complex data types. This is mainly for use by
+other package developers who want to include run-time testing features in
+their own packages.")
+ (license license:gpl3+)))