summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:34:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:51 +0100
commit5e3bd355069649e37eb52d2194e486d8419c51c6 (patch)
tree312be552a11cd615033e6059f999e2c3a5fd5411
parentdcafcfb4fd41016124edd0b24b96214fc3848622 (diff)
downloadguix-patches-5e3bd355069649e37eb52d2194e486d8419c51c6.tar
guix-patches-5e3bd355069649e37eb52d2194e486d8419c51c6.tar.gz
gnu: Add r-assertive-types.
* gnu/packages/cran.scm (r-assertive-types): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a10d430b9e..b3f45f38f0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9655,3 +9655,29 @@ the state and capabilities of R, the operating system it is running on, and
the IDE being used. This is mainly for use by other package developers who
want to include run-time testing features in their own packages.")
(license license:gpl3+)))
+
+(define-public r-assertive-types
+ (package
+ (name "r-assertive-types")
+ (version "0.0-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.types" version))
+ (sha256
+ (base32
+ "0zxq1jfrzgw95ll7alvm0xnk7aihjdksngq4ya2whyvfjbmv4vdb"))))
+ (properties
+ `((upstream-name . "assertive.types")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertive-base" ,r-assertive-base)
+ ("r-assertive-properties" ,r-assertive-properties)
+ ("r-codetools" ,r-codetools)))
+ (home-page "https://bitbucket.org/richierocks/assertive.types")
+ (synopsis "Assertions to check types of variables")
+ (description
+ "This package provides a set of predicates and assertions for checking
+the types of variables. This is mainly for use by other package developers
+who want to include run-time testing features in their own packages.")
+ (license license:gpl3+)))