summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:35:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:51 +0100
commit50ce8b1e2c83d0a31bba6dfaff1d5035d3a94892 (patch)
tree42b45702fb612f3e1bd97da85f6c18cf5bb1058a
parent1f0a761a14373cfec2baf7b79671ab221ea79845 (diff)
downloadguix-patches-50ce8b1e2c83d0a31bba6dfaff1d5035d3a94892.tar
guix-patches-50ce8b1e2c83d0a31bba6dfaff1d5035d3a94892.tar.gz
gnu: Add r-assertive-code.
* gnu/packages/cran.scm (r-assertive-code): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 158ee16179..ee3852c99c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9707,3 +9707,29 @@ the properties of files and connections. This is mainly for use by other
package developers who want to include run-time testing features in their own
packages.")
(license license:gpl3+)))
+
+(define-public r-assertive-code
+ (package
+ (name "r-assertive-code")
+ (version "0.0-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.code" version))
+ (sha256
+ (base32
+ "1qhbp668zfvhqs8avkhg9amp4zyazz6dsy4fc6kpdmw3sv8yi07g"))))
+ (properties
+ `((upstream-name . "assertive.code")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertive-base" ,r-assertive-base)
+ ("r-assertive-properties" ,r-assertive-properties)
+ ("r-assertive-types" ,r-assertive-types)))
+ (home-page "https://bitbucket.org/richierocks/assertive.code")
+ (synopsis "Assertions to check properties of code")
+ (description
+ "This package provides a set of predicates and assertions for checking
+the properties of code. This is mainly for use by other package developers
+who want to include run-time testing features in their own packages.")
+ (license license:gpl3+)))