summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2021-12-09 08:59:07 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-09 09:13:33 +0100
commit1490e02ea29f4a1b2f5b9453d6f36d5b960964a5 (patch)
tree71a53610ae1540fb3431a4f5ab4dbe47af82c535
parent479742f195132d48f36d0e5ce5cd2f5d2cf4570e (diff)
downloadguix-patches-1490e02ea29f4a1b2f5b9453d6f36d5b960964a5.tar
guix-patches-1490e02ea29f4a1b2f5b9453d6f36d5b960964a5.tar.gz
gnu: Add emacs-dpd.
* gnu/packages/emacs-xyz.scm (emacs-dpd): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e542da0c26..f093e67dd4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21434,6 +21434,32 @@ and might also fail at times but makes it unnecessary to maintain
package recipes.")
(license license:gpl3+)))
+(define-public emacs-dpd
+ ;; XXX: Upstream does not use tag yet. Version is extracted from "dpd.el".
+ (let ((commit "f53f251a58859f375617ce4f257fecc83c8ca5da")
+ (revision "0"))
+ (package
+ (name "emacs-dpd")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/lilyp/emacs-dpd")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nislvaxjb53x2ah330szcca4d595npx6zxrrwa5xximj6365wk0"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-packed" ,emacs-packed)))
+ (home-page "https://gitlab.com/lilyp/emacs-dpd")
+ (synopsis "Deliver packages to package.el")
+ (description
+ "This package provides tools for generating package-desc structures and
+feeding them to package.el library.")
+ (license license:gpl3+))))
+
(define-public emacs-picpocket
(let ((version "41")
(commit "fa3a49f011b5ae139728548fec7375743f61c7c7"))