summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-03 19:50:26 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-06 13:28:01 +0100
commit0820a58b3ca29910efcf39b7f0fcdcbaf2a1364a (patch)
tree6f1c1fc1f172c40e3fce4201531915a77ea4b667
parentdd85efda47ef67125abc18d387730d0f266bdf10 (diff)
downloadguix-patches-0820a58b3ca29910efcf39b7f0fcdcbaf2a1364a.tar
guix-patches-0820a58b3ca29910efcf39b7f0fcdcbaf2a1364a.tar.gz
gnu: xorg: Fix http mirror and uncomment xcb packages.
* guix/download.scm (%mirrors): Fix main http mirror address. * gnu/packages/xorg.scm (libpthread-stubs, libxcb, xcb-proto): Uncomment and add licenses.
-rw-r--r--gnu/packages/xorg.scm141
-rw-r--r--guix/download.scm3
2 files changed, 70 insertions, 74 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index ee6771b34d..ebabcab437 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1341,27 +1341,26 @@
(license license:x11)))
-;; file referenced, but not present on servers
-;; (define-public libpthread-stubs
-;; (package
-;; (name "libpthread-stubs")
-;; (version "0.3")
-;; (source
-;; (origin
-;; (method url-fetch)
-;; (uri (string-append
-;; "mirror://xorg/X11R7.7/src/everything/libpthread-stubs-"
-;; version
-;; ".tar.bz2"))
-;; (sha256
-;; (base32
-;; "16bjv3in19l84hbri41iayvvg4ls9gv1ma0x0qlbmwy67i7dbdim"))))
-;; (build-system gnu-build-system)
-;; (inputs `(("pkg-config" ,pkg-config)))
-;; (home-page #f)
-;; (synopsis #f)
-;; (description #f)
-;; (license license:???)))
+(define-public libpthread-stubs
+ (package
+ (name "libpthread-stubs")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/X11R7.7/src/everything/libpthread-stubs-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "16bjv3in19l84hbri41iayvvg4ls9gv1ma0x0qlbmwy67i7dbdim"))))
+ (build-system gnu-build-system)
+ (inputs `(("pkg-config" ,pkg-config)))
+ (home-page #f)
+ (synopsis #f)
+ (description #f)
+ (license license:x11)))
(define-public libsm
@@ -1492,35 +1491,34 @@
(license license:x11)))
-;; file referenced, but not present on servers
-;; (define-public libxcb
-;; (package
-;; (name "libxcb")
-;; (version "1.8.1")
-;; (source
-;; (origin
-;; (method url-fetch)
-;; (uri (string-append
-;; "mirror://xorg/X11R7.7/src/everything/libxcb-"
-;; version
-;; ".tar.bz2"))
-;; (sha256
-;; (base32
-;; "15icn78x610dvvgnji6b3pyn8nd88lz68hq0w73pcadf78mycmw8"))))
-;; (build-system gnu-build-system)
-;; (inputs
-;; `(("xproto" ,xproto)
-;; ("libxdmcp" ,libxdmcp)
-;; ("xcb-proto" ,xcb-proto)
-;; ("libxau" ,libxau)
-;; ("libpthread-stubs" ,libpthread-stubs)
-;; ("libxslt" ,libxslt)
-;; ("pkg-config" ,pkg-config)
-;; ("python" ,python)))
-;; (home-page #f)
-;; (synopsis #f)
-;; (description #f)
-;; (license license:???)))
+(define-public libxcb
+ (package
+ (name "libxcb")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/X11R7.7/src/everything/libxcb-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "03gspxcdl8r7jwbwg7fyp4cc6zic9z91amp4g5z0wwahx48nix6j"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("xproto" ,xproto)
+ ("libxdmcp" ,libxdmcp)
+ ("xcb-proto" ,xcb-proto)
+ ("libxau" ,libxau)
+ ("libpthread-stubs" ,libpthread-stubs)
+ ("libxslt" ,libxslt)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page #f)
+ (synopsis #f)
+ (description #f)
+ (license license:x11)))
(define-public libxcomposite
@@ -2590,28 +2588,27 @@
(license license:x11)))
-;; file referenced, but not present on servers
-;; (define-public xcb-proto
-;; (package
-;; (name "xcb-proto")
-;; (version "1.7.1")
-;; (source
-;; (origin
-;; (method url-fetch)
-;; (uri (string-append
-;; "mirror://xorg/X11R7.7/src/everything/xcb-proto-"
-;; version
-;; ".tar.bz2"))
-;; (sha256
-;; (base32
-;; "1c11652h9sjynw3scm1pn5z3a6ci888pq7hij8q5n8qrl33icg93"))))
-;; (build-system gnu-build-system)
-;; (inputs
-;; `(("pkg-config" ,pkg-config) ("python" ,python)))
-;; (home-page #f)
-;; (synopsis #f)
-;; (description #f)
-;; (license license:x11)))
+(define-public xcb-proto
+ (package
+ (name "xcb-proto")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/X11R7.7/src/everything/xcb-proto-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0ds4qg6slidrzyz6q9ckq0a19hn6blzpnvciy4brh741gn49jpdd"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("pkg-config" ,pkg-config) ("python" ,python)))
+ (home-page #f)
+ (synopsis #f)
+ (description #f)
+ (license license:x11)))
(define-public xcmiscproto
diff --git a/guix/download.scm b/guix/download.scm
index b6bf6a0822..fa89058702 100644
--- a/guix/download.scm
+++ b/guix/download.scm
@@ -101,8 +101,7 @@
"http://mirrors.ircam.fr/pub/apache/"
"http://apache-mirror.rbc.ru/pub/apache/")
(xorg ; from http://www.x.org/wiki/Releases/Download
- "http://xorg.freedesktop.org/releases/" ; main mirrors
- "http://www.x.org/pub/"
+ "http://www.x.org/releases/" ; main mirrors
"ftp://mirror.csclub.uwaterloo.ca/x.org/" ; North America
"ftp://xorg.mirrors.pair.com/"
"http://mirror.csclub.uwaterloo.ca/x.org/"