summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan <stefan-guix@vodafonemail.de>2021-06-19 20:03:11 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2021-06-19 20:10:03 +0200
commitb04cba9ee533945f90ffd72637f064c60188f945 (patch)
treeeb88368bfd17a54963ea9be554dbcb339455673c
parentc7b2bbc3dee45d75a5cc07a6f0e13ca938d18149 (diff)
downloadguix-patches-b04cba9ee533945f90ffd72637f064c60188f945.tar
guix-patches-b04cba9ee533945f90ffd72637f064c60188f945.tar.gz
gnu: linux-libre: Correct name of EXTRAVERSION, and prepend "-" to content.
* gnu/packages/linux.scm (make-linux-libre): Move the comment for the configuration-file argument to the correct position. (make-linux-libre*): Move the comment for the configuration-file argument to the correct position. Fix name of environment variable EXTRAVERSION. Prepend a hyphen to the content of EXTRAVERSION. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 699a01ee41..904338da73 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -727,9 +727,9 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(define* (make-linux-libre version hash-string supported-systems
#:key
+ (extra-version #f)
;; A function that takes an arch and a variant.
;; See kernel-config for an example.
- (extra-version #f)
(configuration-file #f)
(defconfig "defconfig")
(extra-options %default-extra-linux-options)
@@ -748,9 +748,9 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(define* (make-linux-libre* version source supported-systems
#:key
+ (extra-version #f)
;; A function that takes an arch and a variant.
;; See kernel-config for an example.
- (extra-version #f)
(configuration-file #f)
(defconfig "defconfig")
(extra-options %default-extra-linux-options))
@@ -816,7 +816,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(format #t "`CROSS_COMPILE' set to `~a'~%"
(getenv "CROSS_COMPILE"))))
- (setenv "EXTRA_VERSION" ,extra-version)
+ (setenv "EXTRAVERSION" ,(and extra-version
+ (string-append "-" extra-version)))
(let ((build (assoc-ref %standard-phases 'build))
(config (assoc-ref (or native-inputs inputs) "kconfig")))