summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 12:40:12 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:07:37 +0200
commit6f2c4efb56520f8f63ee7f15f694f5582b4d04c4 (patch)
tree7041726af950101c77b5d7f7a7850d92cfa96c3b
parent0d16905b60bd4dab70dfafdb0a8d6fd29a304c44 (diff)
downloadguix-patches-6f2c4efb56520f8f63ee7f15f694f5582b4d04c4.tar
guix-patches-6f2c4efb56520f8f63ee7f15f694f5582b4d04c4.tar.gz
gnu: Add ruby-addressable.
* gnu/package/ruby.scm (ruby-addressable): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 367832d277..862193f305 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5121,3 +5121,26 @@ register names. Some examples of public suffixes are @code{.com},
@code{.co.uk} and @code{pvt.k12.ma.us}. The Public Suffix List is a list of
all known public suffixes.")
(license license:expat)))
+
+(define-public ruby-addressable
+ (package
+ (name "ruby-addressable")
+ (version "2.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "addressable" version))
+ (sha256
+ (base32
+ "0viqszpkggqi8hq87pqp0xykhvz60g99nwmkwsb0v45kc2liwxvk"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-public-suffix" ,ruby-public-suffix)))
+ (arguments
+ ;; No test target
+ `(#:tests? #f))
+ (home-page "https://github.com/sporkmonger/addressable")
+ (synopsis "Alternative URI implementation")
+ (description "Addressable is a replacement for the URI implementation that
+is part of Ruby's standard library. It more closely conforms to RFC 3986,
+RFC 3987, and RFC 6570 (level 4), providing support for IRIs and URI templates.")
+ (license license:asl2.0)))