summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-26 00:49:57 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-26 01:11:35 -0500
commita41aea131a9ade2e714cfdeb8de36c94d799606c (patch)
treecbd34b51a3ff7f7ed9c876b460f1567749c96cfc
parent3672f515825132be74d9729ed5778daab33ae64e (diff)
downloadguix-patches-a41aea131a9ade2e714cfdeb8de36c94d799606c.tar
guix-patches-a41aea131a9ade2e714cfdeb8de36c94d799606c.tar.gz
gnu: libsoup: Disable the hsts test.
The test was found to fail on i686-linux. * gnu/packages/gnome.scm (libsoup-minimal)[phases] {adjust-tests}: De-register the hsts test.
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4529928840..583b754d01 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4939,12 +4939,12 @@ libxml to ease remote use of the RESTful API.")
((".*/sockets/unconnected.*") ""))
;; These fail because "subdomain.localhost" does not resolve in
- ;; the build environment.
- (substitute* "tests/hsts-test.c"
- ((".*/hsts/basic.*") "")
- ((".*/hsts/subdomains.*") "")
- ((".*/hsts/superdomain.*") "")
- ((".*/hsts/utf8-address.*") ""))
+ ;; the build environment. Moreover, the hsts-test suite fails on
+ ;; i686-linux because of errors from `session_get_uri' like
+ ;; "Unexpected status 200 OK (expected 301 Moved Permanently)"
+ ;; (see: https://gitlab.gnome.org/GNOME/libsoup/-/issues/239).
+ (substitute* "tests/meson.build"
+ ((".*'name': 'hsts'.*") ""))
(substitute* "tests/hsts-db-test.c"
((".*/hsts-db/subdomains.*") "")))))))
(native-inputs
@@ -4971,7 +4971,7 @@ libxml to ease remote use of the RESTful API.")
("zlib" ,zlib)))
(inputs
`(("mit-krb5" ,mit-krb5)
- ("ntlm_auth" ,samba/fixed))) ; For ntlm_auth support
+ ("ntlm_auth" ,samba/fixed))) ; For ntlm_auth support
(home-page "https://wiki.gnome.org/Projects/libsoup")
(synopsis "GLib-based HTTP Library")
(description