summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-08-03 18:24:48 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-08-04 15:57:30 +0200
commit93b3287eb01d631b2df00f5874ea5da91a956dde (patch)
tree595fac7282aff406726fce64f23566c120d33e21
parent37cf7c17e054101a1e571504f4a1ad447f3fffca (diff)
downloadguix-patches-93b3287eb01d631b2df00f5874ea5da91a956dde.tar
guix-patches-93b3287eb01d631b2df00f5874ea5da91a956dde.tar.gz
gnu: rust-walkdir: Don't include minor version in variable name.
* gnu/packages/crates-io.scm (rust-walkdir-2.3): Rename to... (rust-walkdir-2): ...this. (rust-walkdir-1.0): Rename to... (rust-walkdir-1): ...this.
-rw-r--r--gnu/packages/crates-io.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 27d45e6ced..1d189b24cb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -410,7 +410,7 @@ code that is generic with regard to the algebraic entity types.")
(("rust-bitflags" ,rust-bitflags-1)
("rust-line-drawing" ,rust-line-drawing-0.7)
("rust-rusttype" ,rust-rusttype-0.7)
- ("rust-walkdir" ,rust-walkdir-2.3)
+ ("rust-walkdir" ,rust-walkdir-2)
("rust-xdg" ,rust-xdg-2.2)
("rust-xml-rs" ,rust-xml-rs-0.8))
#:cargo-development-inputs
@@ -4283,7 +4283,7 @@ to @code{is_x86_feature_detected}.")
("rust-serde-derive" ,rust-serde-derive-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-tinytemplate" ,rust-tinytemplate-1.0)
- ("rust-walkdir" ,rust-walkdir-2.3))
+ ("rust-walkdir" ,rust-walkdir-2))
#:cargo-development-inputs
(("rust-approx" ,rust-approx-0.3)
("rust-quickcheck" ,rust-quickcheck-0.9)
@@ -4329,7 +4329,7 @@ to @code{is_x86_feature_detected}.")
("rust-serde-derive" ,rust-serde-derive-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-tinytemplate" ,rust-tinytemplate-1.0)
- ("rust-walkdir" ,rust-walkdir-2.3))
+ ("rust-walkdir" ,rust-walkdir-2))
#:cargo-development-inputs
(("rust-approx" ,rust-approx-0.3)
("rust-quickcheck" ,rust-quickcheck-0.8)
@@ -7405,7 +7405,7 @@ implementation that is more efficient for smaller hash keys.")
("rust-byteorder" ,rust-byteorder-1.3)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-core-text" ,rust-core-text-13)
- ("rust-walkdir" ,rust-walkdir-2.3))))
+ ("rust-walkdir" ,rust-walkdir-2))))
(home-page "https://github.com/servo/font-kit")
(synopsis "Cross-platform font loading library")
(description
@@ -9553,7 +9553,7 @@ path simultaneously, and returning all of the globs that matched.")
(arguments
`(#:cargo-inputs
(("rust-ignore" ,rust-ignore-0.4)
- ("rust-walkdir" ,rust-walkdir-2.3))
+ ("rust-walkdir" ,rust-walkdir-2))
#:cargo-development-inputs
(("rust-docmatic" ,rust-docmatic-0.1)
("rust-tempdir" ,rust-tempdir-0.3))))
@@ -9879,7 +9879,7 @@ loading crate.")
("rust-grep-searcher" ,rust-grep-searcher-0.1))
#:cargo-development-inputs
(("rust-termcolor" ,rust-termcolor-1)
- ("rust-walkdir" ,rust-walkdir-2.3))))
+ ("rust-walkdir" ,rust-walkdir-2))))
(home-page "https://github.com/BurntSushi/ripgrep")
(synopsis "Line oriented regex searching as a library")
(description
@@ -10149,7 +10149,7 @@ of gzip files based on the gzip header implementation in the @code{flate2} crate
("rust-serde-json" ,rust-serde-json-1)
("rust-tokio" ,rust-tokio-0.1)
("rust-tokio-rustls" ,rust-tokio-rustls-0.12)
- ("rust-walkdir" ,rust-walkdir-1.0)
+ ("rust-walkdir" ,rust-walkdir-1)
("rust-webpki" ,rust-webpki-0.21)
("rust-webpki-roots" ,rust-webpki-roots-0.17))))
(home-page "https://github.com/hyperium/h2")
@@ -10205,7 +10205,7 @@ IEEE 754-2008 binary16 type.")
("rust-quick-error" ,rust-quick-error-1.2)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
- ("rust-walkdir" ,rust-walkdir-2.3))
+ ("rust-walkdir" ,rust-walkdir-2))
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.2)
("rust-env-logger" ,rust-env-logger-0.6)
@@ -11023,7 +11023,7 @@ SystemTime}}.")
("rust-regex" ,rust-regex-1)
("rust-same-file" ,rust-same-file-1.0)
("rust-thread-local" ,rust-thread-local-1.0)
- ("rust-walkdir" ,rust-walkdir-2.3)
+ ("rust-walkdir" ,rust-walkdir-2)
("rust-winapi-util" ,rust-winapi-util-0.1))
#:cargo-development-inputs
(("rust-crossbeam-channel" ,rust-crossbeam-channel-0.4))))
@@ -11831,7 +11831,7 @@ primitives to an @code{io::Write}.")
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3)
("rust-png" ,rust-png-0.14)
- ("rust-walkdir" ,rust-walkdir-2.3))))
+ ("rust-walkdir" ,rust-walkdir-2))))
(home-page "https://github.com/image-rs/jpeg-decoder")
(synopsis "JPEG decoder")
(description "JPEG decoder written in Rust.")
@@ -14790,7 +14790,7 @@ with all line endings.")
("rust-libc" ,rust-libc-0.2)
("rust-mio" ,rust-mio-0.6)
("rust-mio-extras" ,rust-mio-extras-2)
- ("rust-walkdir" ,rust-walkdir-2.3)
+ ("rust-walkdir" ,rust-walkdir-2)
("rust-winapi" ,rust-winapi-0.3))
#:cargo-development-inputs
(("rust-tempdir" ,rust-tempdir-0.3))))
@@ -18037,7 +18037,7 @@ both WASM and native applications")
(arguments
`(#:cargo-inputs
(("rust-tempdir" ,rust-tempdir-0.3)
- ("rust-walkdir" ,rust-walkdir-1.0))))
+ ("rust-walkdir" ,rust-walkdir-1))))
(home-page "https://github.com/DiamondLovesYou/cargo-pnacl-helper")
(synopsis
"Build script helper for building PNaCl/NaCl C/CXX libraries from source")
@@ -23831,7 +23831,7 @@ variants in pure Rust.")
("rust-bytecount" ,rust-bytecount-0.4)
("rust-cargo-metadata" ,rust-cargo-metadata-0.6)
("rust-serde-json" ,rust-serde-json-1)
- ("rust-walkdir" ,rust-walkdir-2.3))))
+ ("rust-walkdir" ,rust-walkdir-2))))
(home-page "https://github.com/budziq/rust-skeptic")
(synopsis "Test your Rust markdown documentation via Cargo")
(description
@@ -25002,7 +25002,7 @@ cryptographic implementations.")
;("rust-reqwest" ,rust-reqwest-0.10)
("rust-tar" ,rust-tar-0.4)
("rust-termcolor" ,rust-termcolor-1)
- ("rust-walkdir" ,rust-walkdir-2.3))))
+ ("rust-walkdir" ,rust-walkdir-2))))
(home-page "https://github.com/dtolnay/syn")
(synopsis "Parser for Rust source code")
(description "Parser for Rust source code")
@@ -25034,7 +25034,7 @@ cryptographic implementations.")
("rust-ref-cast" ,rust-ref-cast-0.2)
("rust-regex" ,rust-regex-1)
("rust-termcolor" ,rust-termcolor-1)
- ("rust-walkdir" ,rust-walkdir-2.3))))
+ ("rust-walkdir" ,rust-walkdir-2))))
(properties '())))
(define-public rust-syn-0.11
@@ -25067,7 +25067,7 @@ cryptographic implementations.")
(("rust-syntex-pos" ,rust-syntex-pos-0.58)
("rust-syntex-syntax" ,rust-syntex-syntax-0.58)
("rust-tempdir" ,rust-tempdir-0.3)
- ("rust-walkdir" ,rust-walkdir-1.0))))))
+ ("rust-walkdir" ,rust-walkdir-1))))))
(define-public rust-syn-mid-0.5
(package
@@ -25232,7 +25232,7 @@ cryptographic implementations.")
("rust-lazycell" ,rust-lazycell-1.2)
("rust-bincode" ,rust-bincode-1)
("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-walkdir" ,rust-walkdir-2.3)
+ ("rust-walkdir" ,rust-walkdir-2)
("rust-onig" ,rust-onig-5.0))))
(home-page "https://github.com/trishume/syntect")
(synopsis "Library for syntax highlighting and code intelligence")
@@ -25365,7 +25365,7 @@ syntax extension expansion.")
("rust-byteorder" ,rust-byteorder-1.3)
("rust-failure" ,rust-failure-0.1)
("rust-libc" ,rust-libc-0.2)
- ("rust-walkdir" ,rust-walkdir-2.3))))
+ ("rust-walkdir" ,rust-walkdir-2))))
(home-page "https://github.com/johalun/sysctl-rs")
(synopsis "Simplified interface to libc::sysctl")
(description
@@ -28450,7 +28450,7 @@ updated when the crate version changes.")
specified across Unix and Windows platforms.")
(license (list license:expat license:asl2.0))))
-(define-public rust-walkdir-2.3
+(define-public rust-walkdir-2
(package
(name "rust-walkdir")
(version "2.3.1")
@@ -28475,9 +28475,9 @@ specified across Unix and Windows platforms.")
(description "Recursively walk a directory.")
(license (list license:unlicense license:expat))))
-(define-public rust-walkdir-1.0
+(define-public rust-walkdir-1
(package
- (inherit rust-walkdir-2.3)
+ (inherit rust-walkdir-2)
(name "rust-walkdir")
(version "1.0.7")
(source
@@ -30208,7 +30208,7 @@ implementation that works everywhere, even WASM!")
#:cargo-development-inputs
(("rust-bencher" ,rust-bencher-0.1)
("rust-rand" ,rust-rand-0.4)
- ("rust-walkdir" ,rust-walkdir-1.0))))
+ ("rust-walkdir" ,rust-walkdir-1))))
(home-page "https://github.com/mvdnes/zip-rs.git")
(synopsis
"Library to support the reading and writing of zip files")