summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-04 11:05:07 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-04 11:11:08 +0300
commit062448f35917fe26553c8e2c7aa1b35f95ae4f1a (patch)
treee90c9e4fb5bd52948485c58e8705c495456080c9
parent7f101e7ceb869882b9a959cb7801aea64c26704d (diff)
downloadguix-patches-062448f35917fe26553c8e2c7aa1b35f95ae4f1a.tar
guix-patches-062448f35917fe26553c8e2c7aa1b35f95ae4f1a.tar.gz
gnu: Add paperview.
* gnu/packages/games.scm (paperview): New variable.
-rw-r--r--gnu/packages/games.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0f79f5eeba..9c415bc174 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11707,3 +11707,35 @@ computer opponents or against real players online.")
"Pilot your ship inside a planet to find and rescue the colonists trapped
inside the Zenith Colony.")
(license license:gpl3+)))
+
+(define-public paperview
+ (let ((commit "9f8538eb6734c76877b878b8f1e52587f2ae19e6")
+ (revision "1"))
+ (package
+ (name "paperview")
+ (version (git-version "0.0.1" revision commit)) ;no upstream release
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/glouw/paperview")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09sb9sg44fvkgfdyycrm1ndpx7cnkrglxhci41y8f3gpagnvi7jk"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("sdl2" ,sdl2)))
+ (arguments
+ '(#:tests? #f ;no tests
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/glouw/paperview/")
+ (synopsis "High performance X11 animated wallpaper setter")
+ (description "High performance animated desktop background setter for
+X11 that won't set your CPU on fire, drain your laptop battery, or lower video
+game FPS.")
+ (license license:unlicense))))