summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-01-14 23:40:22 +0000
committerVinicius Monego <monego@posteo.net>2022-01-30 11:46:18 -0300
commit527ee1bdc82d608dc41438c4f3c6e86260aecb85 (patch)
treeddb0fc104c8ef23e98f21de929f993cb312ebacc
parent89a5c53f382eec3dc4e2b60d819b39ada003df44 (diff)
downloadguix-patches-527ee1bdc82d608dc41438c4f3c6e86260aecb85.tar
guix-patches-527ee1bdc82d608dc41438c4f3c6e86260aecb85.tar.gz
gnu: Add python-asdf-coordinates-schemas.
* gnu/packages/astronomy.scm (python-asdf-coordinates-schemas): New variable. Signed-off-by: Vinicius Monego <monego@posteo.net>
-rw-r--r--gnu/packages/astronomy.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b19282b37c..9df0934d08 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1523,6 +1523,38 @@ should not need to install this directly; instead, install an implementation
package such as asdf-astropy.")
(license license:bsd-3)))
+(define python-asdf-coordinates-schemas
+ (package
+ (name "python-asdf-coordinates-schemas")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf_coordinates_schemas" version))
+ (sha256
+ (base32 "0ahwhsz5jzljnpkfd2kvspirg823lnj5ip9sfkd9cx09z1nlz8jg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ (list python-pytest
+ python-semantic-version
+ python-setuptools-scm))
+ (propagated-inputs
+ (list python-asdf))
+ (home-page "https://github.com/asdf-format/asdf-coordinates-schemas")
+ (synopsis "ASDF coordinates schemas")
+ (description "This package provides ASDF schemas for validating
+coordinates tags. Users should not need to install this directly; instead,
+install an implementation package such as asdf-astropy.")
+ (license license:bsd-3)))
+
(define-public python-astroalign
(package
(name "python-astroalign")