summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-18 11:47:40 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-20 14:25:30 +0100
commit6754032f0c908f09cb1fc9577133b712651aec69 (patch)
tree1e607171b840499e743adaf5e1fbadbbdb2b9fac
parent76aae0f96f3aed10e842b1726ffc19848600c04d (diff)
downloadguix-patches-6754032f0c908f09cb1fc9577133b712651aec69.tar
guix-patches-6754032f0c908f09cb1fc9577133b712651aec69.tar.gz
gnu: matplotlib: install UTF-8 locale.
* gnu/packages/python.scm (python-matplotlib): Install en_US.UTF-8 locale in install-doc phase to avoid encoding error.
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6fe524e83a..7dc7435b20 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2259,7 +2259,11 @@ backend = GTK3Agg~%")))))
(info (string-append data "/info"))
(html (string-append doc "/html")))
(with-directory-excursion "doc"
- ;; Without setting this variable we get an encoding error.
+ ;; Install and set UTF-8 locale to avoid an encoding error.
+ (setenv "LOCPATH" (getcwd))
+ (system* "localedef" "--no-archive"
+ "--prefix" (getcwd) "-i" "en_US"
+ "-f" "UTF-8" "./en_US.UTF-8")
(setenv "LANG" "en_US.UTF-8")
;; Produce pdf in 'A4' format.
(substitute* (find-files "." "conf\\.py")