summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-29 17:58:21 -0500
committerLeo Famulari <leo@famulari.name>2022-01-29 17:59:30 -0500
commitdb17f8b5023122fdc37ab7de5b927303cc4209f9 (patch)
tree3f5e4d8b65d87c46d0aa78fdd96202838193cc9e
parentf8bfb2d85682dcabe56a4b1b0f25d566a0abbd2b (diff)
downloadguix-patches-db17f8b5023122fdc37ab7de5b927303cc4209f9.tar
guix-patches-db17f8b5023122fdc37ab7de5b927303cc4209f9.tar.gz
gnu: fcitx5-chinese-addons: Replace the dependency on QtWebKit with QtWebEngine.
See <https://issues.guix.gnu.org/53289> for more information about this change. * gnu/packages/fcitx5.scm (fcitx5-chinese-addons)[inputs]: Remove qtwebkit. Add qtdeclarative, qtwebchannel, and qtwebengine. [arguments]: Pass "-DUSE_WEBKIT=off" to #:configure-flags.
-rw-r--r--gnu/packages/fcitx5.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 92fc0ea171..66b07b4a51 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -284,7 +284,9 @@ for Qt based application.")
(base32 "11l76gpcfm0x1f6x5m9s37q7ffa7xcsdydlzjdz2s6kk45fvvq89"))))
(build-system cmake-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags
+ '("-DUSE_WEBKIT=off")
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'split-outputs
;; Build with GUI supports requires Qt and increase package closure
@@ -305,7 +307,9 @@ for Qt based application.")
("opencc" ,opencc)
("qtbase" ,qtbase-5)
("fcitx5-qt" ,fcitx5-qt)
- ("qtwebkit" ,qtwebkit)))
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebchannel" ,qtwebchannel)
+ ("qtwebengine" ,qtwebengine)))
(native-inputs
(list extra-cmake-modules pkg-config))
(outputs '("out" "gui"))