summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-25 15:17:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-25 15:28:00 +0300
commitfc899d4f73a9af38af5c1b11ddd150e4c21341a0 (patch)
treee13243f517a8eb129fb56d4d0639391a6c26bf52
parent426037267122c5b7671f6492ff277bbffe3bc6fb (diff)
downloadguix-patches-fc899d4f73a9af38af5c1b11ddd150e4c21341a0.tar
guix-patches-fc899d4f73a9af38af5c1b11ddd150e4c21341a0.tar.gz
gnu: python-seaborn: Update to 0.7.0.
* gnu/packages/python.scm (python-seaborn): Update to 0.7.0. [native-inputs]: Remove python-setuptools. (python2-seaborn): Build with 'strip-python2-variant'. [propagated-inputs]: Add python2-pytz. [native-inputs]: Add python2-setuptools.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f1093da65f..a798934eca 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4752,22 +4752,18 @@ Python style, together with a fast and comfortable execution environment.")
(define-public python-seaborn
(package
(name "python-seaborn")
- (version "0.5.1")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://pypi.python.org/packages/source/s/seaborn/seaborn-"
- version ".tar.gz"))
+ (uri (pypi-uri "seaborn" version))
(sha256
- (base32 "1236abw18ijjglmv60q85ckqrvgf5qyy4zlq7nz5aqfg6q87z3wc"))))
+ (base32 "0ibi3xsfm2kysph61mnfy0pf8d5rkgxgrdb0z9nbizgcgdsb5a0m"))))
(build-system python-build-system)
(propagated-inputs
`(("python-pandas" ,python-pandas)
("python-matplotlib" ,python-matplotlib)
("python-scipy" ,python-scipy)))
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
(home-page "http://stanford.edu/~mwaskom/software/seaborn/")
(synopsis "Statistical data visualization")
(description
@@ -4775,16 +4771,17 @@ Python style, together with a fast and comfortable execution environment.")
graphics in Python. It is built on top of matplotlib and tightly integrated
with the PyData stack, including support for numpy and pandas data structures
and statistical routines from scipy and statsmodels.")
- (license bsd-3)))
+ (license bsd-3)
+ (properties `((python2-variant . ,(delay python2-seaborn))))))
(define-public python2-seaborn
- (let ((seaborn (package-with-python2 python-seaborn)))
- (package (inherit seaborn)
- (propagated-inputs
- `(("python2-pytz" ,python2-pytz)
- ("python2-pandas" ,python2-pandas)
- ("python2-matplotlib" ,python2-matplotlib)
- ("python2-scipy" ,python2-scipy))))))
+ (let ((base (package-with-python2 (strip-python2-variant python-seaborn))))
+ (package
+ (inherit base)
+ (propagated-inputs `(("python2-pytz" ,python2-pytz)
+ ,@(package-propagated-inputs base)))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))
(define-public python-sympy
(package